Bug 12189 - ifup starts 2 copies of wpa_supplicant
: ifup starts 2 copies of wpa_supplicant
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/etcnet)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-07-01 01:32 by
Modified: 2016-04-08 12:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-07-01 01:32:15
USB DLink-122G wireless.
cat /etc/net/ifaces/wlan0/options:
TYPE=eth
MODULE=ndiswrapper
NEVER_RMMOD=yes
BOOTPROTO=dhcp
USE_HOTPLUG=yes
ONBOOT=no
WPA_DRIVER=wext
Сразу после загрузке системы сделать ifup wlan0: говорит о том, что в
/var/run/wpa_supplicant уже есть его файл интерфейса. Соотв., wpa_supplicant не
коннектиться, и тупо висит - сети нет. Если его прибить, и _ЕЩЕ_ раз сделать
ifup wlan0 - все нормально стартует.
ДО запуска ifup файла в /var/run/... нет.
Пытаясь разобраться, я подменил /usr/bin/wpa_supplicant на скрипт, который
печатает список процессов, удаляет файл интерфейса из /var/run/wpa_supplicant, и
и запускает настоящий wpa_supplicant.
В итоге обнаружил ДВА вывода списка процессов: оба раза wpa_supplicant
запускается через команду config-wireless wlan0.
Видимо, где то гонка.
Steps to Reproduce:
1.Загрузиться
2.Вставить usb wireless в порт USB
3.Сказать ifup wlan0
Actual Results:  
висит процесс wpa_supplicant, dhcpcd (в скоре отваливается по таймату)

Expected Results:  
поднятая сеть!!!
------- Comment #1 From 2008-06-13 13:00:39 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #2 From 2016-04-08 12:06:21 -------
давно не наблюдалось