Bug 12224 - последний fbreader не запускается
: последний fbreader не запускается
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/fbreader)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-07-05 22:31 by
Modified: 2008-08-27 05:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-07-05 22:31:59
при запуске получаю такую красоту
FBReader: symbol lookup error: /usr/lib/libzlibrary-qt4.so.0.8.4: undefined
symbol: _ZN9QListView16selectionChangedERK14QItemSelectionS2_
rpm -q fbreader fbreader-0.8.4-alt1
------- Comment #1 From 2007-07-05 22:43:00 -------
А в каком окружении выполняется запуск ?

Зерг, можешь прокомментировать ?
------- Comment #2 From 2007-07-06 00:33:21 -------
(In reply to comment #1)
> А в каком окружении выполняется запуск ?
> 
> Зерг, можешь прокомментировать ?

Было
qt4-settings-4.2-alt1
libqt4-core-4.2.3-alt8
libqt4-network-4.2.3-alt8
qt4-common-4.2.3-alt8
libqt4-xml-4.2.3-alt8
libqt4-gui-4.2.3-alt8

apt-get install libqt4-core

Стало
libqt4-network-4.3.0-alt3
libqt4-gui-4.3.0-alt3
qt4-common-4.3.0-alt3
libqt4-xml-4.3.0-alt3
qt4-settings-4.3-alt1
libqt4-core-4.3.0-alt3

Все работает
------- Comment #3 From 2007-07-06 10:15:49 -------
Другими словами, fbreader в бранче не работает и не будет работать до тех пор,
пока там не будет обновлён пакет libqt4-core?

В таком случае почему у пакета fbreader нет необходимых зависимостей?
------- Comment #4 From 2007-07-06 10:45:15 -------
Вот мне тоже интересно, почему у fbreader не появилась такая зависимость при
сборке. Если API Qt4 плывёт, то видимо должна автоматом появляться такая
зависимость ?
------- Comment #5 From 2007-07-06 15:49:38 -------
(In reply to comment #4)
> Вот мне тоже интересно, почему у fbreader не появилась такая зависимость при
> сборке. Если API Qt4 плывёт, то видимо должна автоматом появляться такая
> зависимость ?
Это нереально. Qt в зависимости от опций configure может вкл/выкл чать API
Есдинственное, что я стараюсь выключаю ничего сам.
А список export-а убъешься вести для таких толстых библиотек.

В spec достаточно написать
Requires: libqt4-core %{get_version libqt4-core}
это решает такие проблемы с конкретным пакетом
------- Comment #6 From 2007-09-10 23:36:38 -------
fbreader-0.8.6c-alt1 и libqt4-core-4.3.1-alt2/alt3 из бранча у меня работают. 
FIXED?
------- Comment #7 From 2007-09-11 01:01:54 -------
ok