Bug 12232 - [4.1] warn on "cpio: read failed - Input/output error" please
: [4.1] warn on "cpio: read failed - Input/output error" please
Status: NEW
: Sisyphus
(All bugs in Sisyphus/installer)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 12001
: 12100 14168
  Show dependency tree
 
Reported: 2007-07-06 12:07 by
Modified: 2008-07-16 02:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-07-06 12:07:10
Необходимо добавить реакцию на ошибки чтения с диска или из удалённого
репозитория.  Только не блокировать без вариантов процесс, а спросить -- "так
чо, дальше едем или хватит?" (по умолчанию, наверное, "хватит")

По-хорошему и media check при загрузке с CD не помешает; вешать отдельную багу?
(и надо ли отдельную на alterator-install2-server?)

[10:19:57] <funky> правил листы, апдэйтил, потом ставлю мс - оно мне по морде
чайником
[10:45:16] <gvy> чудеса
[10:45:28] <gvy> так эта... стоп.  смотря что в листах правил
[10:45:51] <gvy> покажи-ка grep -rv ^# /etc/apt/sources.list* | grep -v ^$
[10:45:54] <funky> # ALT Linux 4.0 Server (main+contrib)
rpm [security] ftp://ftp.linux.kiev.ua/pub/Linux/ALT/4.0/Server/current i586
classic

# ALT Linux 4.0 (updates)
rpm [updates] ftp://ftp.linux.kiev.ua/pub/Linux/ALT/updates/4.0 i586 updates
[10:46:06] <gvy> гм, вроде да
[10:46:11] <gvy> а что сказало, гришь?
[10:46:26] <funky> вот это
[root@br ~]# apt-get install mc
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these:
The following packages have unmet dependencies:
hasher: Depends: cpio-static but it is not going to be installed
mc: Depends: libslang (>= 1.4.9) but it is not going to be installed
    Depends: libglib-2.0.so.0
    Depends: libslang.so.1
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or
specify a solution).
[10:46:28] <gvy> (история дома0
[10:46:45] <gvy> а если сказать apt-get install libslang
?
[10:48:26] <funky> пробовал apt-get install libslang - оно ругалось на
cpio-static, как - не помню, но тоже советовало пофиксить броукен -f

вылечилось так - apt-get install cpio-static, потом cpio-static mc
и все, без вопросов
[10:48:53] <funky> само оно не могло почемуто
[10:56:32] <funky> слушай, мих
а может быть это из -за того что диск плохо читался?....
[10:56:43] <funky> может просто cpio-static не стал
[10:58:20] <funky> все ясно

[root@br .install-log]# cat basesystem.log | grep cpio
pkg[129]=cpio-2.6-alt17
pkg[130]=cpio-static-2.6-alt17
error: unpacking of archive failed on file /usr/bin/cpio.static;468bbfbb: cpio:
read failed - Input/output error
[10:58:26] <gvy> ммм... от такого что угодно может быть
[10:58:30] <gvy> а, ну дык
[10:59:02] <gvy> повесь-ка багу на alterator-install2, чтоб хотя бы ругался на
такое в морду (и спрашивал, ехать дальше или всё-таки нет)
------- Comment #1 From 2007-08-01 15:00:09 -------
не в этой версии
------- Comment #2 From 2007-08-06 23:02:23 -------
OK
------- Comment #3 From 2007-11-10 18:40:53 -------
Это тоже нужно, но скорее всего после #12001 (то будто проще? и очевидней).
------- Comment #4 From 2008-02-15 23:30:46 -------
re
------- Comment #5 From 2008-02-15 23:31:27 -------
-> installer; reassign