Bug 1233 - libgtk+2-devel - missing requires
: libgtk+2-devel - missing requires
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libgtk+2-devel)
: unstable
: all Linux
: P4 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-08-30 13:25 by
Modified: 2006-05-28 00:55 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-08-30 13:25:41
В зависимостях libgtk+2-devel не хватает
libpango-devel
libatk-devel

Во всяком случае,
$ pkg-config --cflags --libs gtk+-2.0
без них ругался.

libgtk+2-devel-2.0.5-alt1
---

---

------- Comment #1 From 2002-09-02 11:43:35 -------
Также не хватает зависимости на lfreetype (freetype[2]-devel).
------- Comment #2 From 2002-09-02 11:43:35 -------
Также не хватает зависимости на lfreetype (freetype[2]-devel).
------- Comment #3 From 2005-10-15 12:29:20 -------
$ rpm --requires libgtk+2-devel | grep devel 
glib2-devel >= 2.7.1 
libatk-devel >= 1.9.0 
libpango-devel >= 1.9.0 
freetype2-devel 
------- Comment #4 From 2005-12-06 15:27:33 -------
А также не хватает libpng12 :

[builder@amp src]$ pkg-config --libs gtk+-2.0 ; echo $? 
Package libpng12 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libpng12.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libpng12', required by 'cairo', not found
------- Comment #5 From 2006-04-27 17:06:01 -------
reassign; до сих пор не просит ни libfreetype-devel, ни libpng12-devel.
------- Comment #6 From 2006-05-28 00:55:25 -------
(In reply to comment #5)
> reassign; до сих пор не просит ни libfreetype-devel, ни libpng12-devel.
Обе зависимости относятся к libcairo-devel, а не к libgtk+2-devel. Основание -
содержимое файлов gtk*.pc и cairo.pc
Лучше всего, наверное, завести отдельный баг об этом.