Bug 12835 - 85Hz на TFT мониторе при установке.
: 85Hz на TFT мониторе при установке.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/design-bootloader-installer-desktop)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-09-19 11:32 by
Modified: 2008-06-26 11:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-09-19 11:32:43
При старте X сервера, при установке Desktop4 на TFT монитор 85Hz.
Проверено на следующих мониторах:
RoverScan Smart 151 15"
Samsung SM 940N
Samsung SM 913N

Через некоторое время монитор уходит в защиту. Приходится выключать и включать
его заново. И какое то время можно продолжать установку, после чего процедура
повторяется.
------- Comment #1 From 2007-09-19 19:30:46 -------
А что происходит, если указать xdriver=vesa как параметр ядру ?
------- Comment #2 From 2007-09-20 08:10:35 -------
О! Забыл указать. В испытаниях принимали участие компьютеры в которых
видеокарты
Radeon >= 9600.
vesa не пробовал.
------- Comment #3 From 2007-09-20 14:44:15 -------
Пожалуйста, попробуйте xdriver=vesa
------- Comment #4 From 2007-09-22 09:37:53 -------
(In reply to comment #3)
> Пожалуйста, попробуйте xdriver=vesa
> 

С ним всё нормально. Значит дело в fglrx драйвере?
Но тогда как объяснить, что после установки этого глюка нет с тем же драйвером?
------- Comment #5 From 2008-01-15 18:46:36 -------
Возможен следующий сценарий:
Известно, что драйвер fglrx приводит к неработоспособности ddcprobe. 
Но в инсталляторе ddcprobe отрабатывает раньше чем запускается xorg с этим
драйвером.

Соотв. различается то как прописан монитор в системе и в инсталляторе.

Как это лечить не понятно ибо иногда наблюдается прямо противоположный эффект.

Разве что в инсталляторе в режиме failsafe отключать детект монитора или сделать
вообще какой-то отдельный ключик для отключения детекта монитора.

Было бы любопытно посмотреть на /etc/X11/xorg.conf который делает инсталлятор.

Для получения файла можно запустить инсталлятор с параметром instdebug. В этом
случае запуска xorg не будет.
------- Comment #6 From 2008-06-26 11:47:30 -------
После переустановки дома системы глюка не наблюдаю...