Bug 12863 - Overbloated dependencies
: Overbloated dependencies
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xdg-utils)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-09-21 01:26 by
Modified: 2007-10-24 18:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-09-21 01:26:07
$ apt-cache show xdg-utils | grep Description
Description: A set of command line tools that assist applications with a variety
of desktop integration tasks

$ sudo apt-get install xdg-utils
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  design-graphics-sisyphus kde-common kde-settings kdebase-common kdebase-konqueror
  kdebase-libkonq kdelibs libarts-qtmcop libavahi-qt3 libexo libxfce4util
The following NEW packages will be installed:
  design-graphics-sisyphus kde-common kde-settings kdebase-common kdebase-konqueror
  kdebase-libkonq kdelibs libarts-qtmcop libavahi-qt3 libexo libxfce4util xdg-utils
0 upgraded, 12 newly installed, 0 removed and 13 not upgraded.
Need to get 21.5MB of archives.
After unpacking 47.1MB of additional disk space will be used.
Do you want to continue? [Y/n] 

И это не считая установленного гнома.  Не многовато ли для "set of command line
tools"?
------- Comment #1 From 2007-09-21 09:32:21 -------
Исправлено в 
xdg-utils-1.0.2-alt1.src.rpm
P.S.
XFCE тоже установлено? :)
------- Comment #2 From 2007-09-21 23:27:05 -------
Нет, оно ведь тянет libexo и libxfce4util.

На самом деле глянул я внутрь и срочно захотелось всё переписать, такое оно
страшенное...
------- Comment #3 From 2007-09-22 00:22:45 -------
Ну да, внутри не очень, но может быть сойдёт как основа. На самом деле давно 
мечтаю о том, что mc, к примеру, сможет запускать обработчики файлов на основе 
desktop-ассоциаций, а не по своим устаревшим правилам.