Bug 13080 - Странное название для статической библиотеки
: Странное название для статической библиотеки
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/SimGear)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-11 00:57 by
Modified: 2007-12-25 17:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-11 00:57:47
$ rpm -ql SimGear
/usr/lib/libsgbucket.a
/usr/lib/libsgdebug.a
....

Вроде бы пакет должно назвать libsimgear-devel-static
------- Comment #1 From 2007-10-12 10:50:26 -------
Уж какое есть.  Используется она только для FlightGear (когда-то там был
напильник про динамическую линковку, но он никуда не прошёл и к следующей
версии
был выкинут).

Если честно, то мне лень трогать два пакета, один из которых толстый, ради
таких
мелочей.  А когда выйдет FG 0.9.11, думаю, и так вспомню.

=> остаётся NEW, но вообще-то WORKSFORME :)
------- Comment #2 From 2007-11-11 00:34:05 -------
Меня устраивает, в общем.
------- Comment #3 From 2007-11-11 01:01:44 -------
Согласно полиси пакет должен называться libsimgear-devel
Не забудь вспомнить...
------- Comment #4 From 2007-11-11 20:04:48 -------
Уф.  Убедил:

Статические библиотеки

Статические библиотеки должны паковаться в отдельные подпакеты, что связано со
спецификой их использования. Если имя devel-подпакета заканчивается суффиксом
-devel, то имя нового devel-static-подпакета будет заканчиваться суффиксом
-devel-static. При разделении подпакетов следует помнить о внутрипакетных
зависимостях: в списке зависимостей devel-static-подпакета должна присутствовать
зависимость от -devel = %version-%release. 

-- но этот пакет можно считать хоть данными, он привязан к FG [пока].  Вспомнить
постараюсь, но выходит оно всё нечасто.
------- Comment #5 From 2007-12-22 15:36:45 -------
Вышла версия 1.0. :)
------- Comment #6 From 2007-12-25 17:09:18 -------
fixed in 1.0.0-alt1, только выкладывать лучше вместе с FG-1.0.0, в котором
fgrun
починить надо.  Если что, у меня в git есть.