Bug 13155 - 0.55.0-alt2 seems broken
: 0.55.0-alt2 seems broken
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/gtk2-themes-qtcurve)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-18 21:38 by
Modified: 2007-10-21 15:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-18 21:38:51
gtk2-themes-qtcurve-0.55.0-alt2

При запуске переключалки тем ругается так:

~$ gtk2-theme-switch

(gtk2-theme-switch:19057): Gtk-WARNING **: GModule
(/usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so) initialization check failed:
Gtk+ version too old (micro mismatch)

(gtk2-theme-switch:19057): Gtk-WARNING **: GModule
(/usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so) initialization check failed:
Gtk+ version too old (micro mismatch)

И не переключает теме вообще. Т.е. для всех приложений устанавливается тема по
умолчанию.

Версий пакетов в системе:

~$ rpm -qa G 'gtk\+'
libgtk+2-2.10.14-alt1
libgtk+2-common-devel-2.10.14-alt1
libgtk+2-common-2.10.14-alt1
gtk+-devel-1.2.10-alt15
libgtk+2-devel-2.10.14-alt1
gtk+-1.2.10-alt15
~$ rpm -qa G 'gtk2'                                                   
gtk2-theme-switch-2.0.0rc2-alt1
perl-Gtk2-1.132-alt2
gtk2-themes-qtcurve-0.52.3-alt2

Откат на 0.52.3-alt2 помогает - выбор тем снова работает.

Actual Results:
------- Comment #1 From 2007-10-18 21:49:00 -------
он собран под libgtk+2-2.12.0
------- Comment #2 From 2007-10-18 23:57:06 -------
Сделайте -alt2 с Requires: libgtk+2 >= 2.12.0 тогда, что ли... Я понимаю, что
не
очень красиво, но что ж делать, если апстрим невменяем в плане зависимостей по
версиям.