Bug 13187 - На gf7025 не загружается автоматически forcedeth
: На gf7025 не загружается автоматически forcedeth
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std-smp)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-23 11:37 by
Modified: 2008-01-25 18:09 (History)


Attachments
Sysreport с проблемной машины (21.55 KB, application/octet-stream)
2007-10-23 11:38, Anton V. Boyarshinov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-23 11:37:13
На gf7025 не загружается автоматически forcedeth, предположительно изза нового
pciid.
------- Comment #1 From 2007-10-23 11:38:11 -------
Created an attachment (id=2232) [details]
Sysreport с проблемной машины
------- Comment #2 From 2007-10-25 05:41:05 -------
(In reply to comment #0)
> На gf7025 не загружается автоматически forcedeth, предположительно изза 
нового
> pciid.

В include/linux/pci_ids.h не хватает:
#define PCI_DEVICE_ID_NVIDIA_NVENET_24              0x054C
------- Comment #3 From 2007-10-31 15:11:58 -------
Тж. #12221?
------- Comment #4 From 2007-11-01 16:16:22 -------
Исходя из ядер 2.6.18-std-smp-alt8.2 и 2.6.22-led-smp-alt0.1, доступных здесь:
ftp://ftp.linux.kiev.ua/pub/Linux/ALT/people/led/Sisyphus/ -- могу сказать, что
на 2.6.18 с несколько обновлённым/исправленным forcedeth не завелось, на 2.6.22
-- поехало.

(это мне сегодня как раз 7025 на голову и свалилось)
------- Comment #5 From 2007-11-01 17:50:21 -------
(In reply to comment #4)
> Исходя из ядер 2.6.18-std-smp-alt8.2 и 2.6.22-led-smp-alt0.1, доступных 
> на 2.6.18 с несколько обновлённым/исправленным forcedeth не завелось
> (это мне сегодня как раз 7025 на голову и свалилось)

В 2.6.18-std-smp-alt8.2 ещё нет 7025. Но обновлённый патч (с поддержкой 7025) 
для forcedeth уже есть.
2.6.18-std-smp-alt8.3 я, скорее всего, собирать не буду, потому как считаю 
некорректным называть свои сборки std-smp, чтобы не вводить в заблуждение: там 
уже достаточно много изменений, по сравнению с ALT-мэйнстрим 
kernel-image-std-smp. Сорее всего, это будут kernel-image-led-(std,svr,wks).
------- Comment #6 From 2007-12-24 16:52:34 -------
Должно работать с kernel-image-std-smp 2.6.18-alt10 (уже в branch 4.0).
------- Comment #7 From 2008-01-25 18:09:33 -------
С alt11 тоже уже работает, спасибо!