Bug 13193 - Плохо работает ffmpeg
: Плохо работает ffmpeg
Status: CLOSED FIXED
: Branch 4.1
(All bugs in Branch 4.1/ffmpeg)
: unspecified
: all Linux
: P2 normal
Assigned To:
:
:
:
: 13198
:
  Show dependency tree
 
Reported: 2007-10-23 14:34 by
Modified: 2008-09-23 21:15 (History)


Attachments
WMV (349.58 KB, video/x-ms-wmv)
2007-10-23 14:39, Vitaly Kuznetsov
no flags Details
FLV (458.30 KB, application/octet-stream)
2007-10-23 14:39, Vitaly Kuznetsov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-23 14:34:07
Сообщение от клиента:

Здравствуйте.
Плохо работает ffmpeg на машине 217.16.24.54
Прилагаю 2 файла (исходный wmv и результат - flv).
Использовал команду:
ffmpeg -i "/var/www/site/kadochnikov.info/htdocs/files/296_8seconds2.wmv" -f flv
-acodec libmp3lame -ar 11025 -ab 32k -ac 1 -b 128k
"/var/www/site/kadochnikov.info/htdocs/files/videoout/296_8seconds2.flv"

В убунте 7.04 ffmpeg конвертирует без искажений.
Вот, что пишет ffmpeg -version в Убунте:

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
 configuration:  --enable-gpl --enable-pp --enable-pthreads --enable-vorbis
--enable-libogg --enable-a52 --enable-dts --enable-libgsm --enable-dc1394
--disable-debug --enable-mp3lame --enable-faadbin --enable-faad --enable-faac
--enable-xvid --enable-x264 --enable-amr_nb --enable-amr_wb --enable-shared
--prefix=/usr
 libavutil version: 0d.49.0.0
 libavcodec version: 0d.51.11.0
 libavformat version: 0d.50.5.0
 built on Mar 21 2007 14:14:05, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
ffmpeg      SVN-rUNKNOWN
libavutil   3211264
libavcodec  3345152
libavformat 3278080 

файлики сейчас приложу
------- Comment #1 From 2007-10-23 14:39:06 -------
Created an attachment (id=2234) [details]
WMV
------- Comment #2 From 2007-10-23 14:39:58 -------
Created an attachment (id=2235) [details]
FLV
------- Comment #3 From 2007-10-23 14:41:10 -------
а наша-то версия ffmpeg какая?
------- Comment #4 From 2007-10-23 14:56:48 -------
текущая из branch/4.0

FFmpeg version SVN-r10150, Copyright (c) 2000-2007 Fabrice Bellard, et al.
All the errors with this package you should report
to ALT Linux Bugzilla (https://bugzilla.altlinux.org),
and NOT to ffmpeg authors.
  libavutil version: 49.5.0
  libavcodec version: 51.41.0
  libavformat version: 51.12.2
  built on Oct  4 2007 10:14:33, gcc: 4.1.1 20070105 (ALT Linux, build 4.1.1-alt11)
------- Comment #5 From 2007-10-23 14:58:47 -------
(In reply to comment #4)
> текущая из branch/4.0
> 
> FFmpeg version SVN-r10150, Copyright (c) 2000-2007 Fabrice Bellard, et al.

Попробуйте с текущей Сизифовской. Если заработает, то есть смысл положить в
бранч версию поновее.
------- Comment #6 From 2007-10-23 15:17:13 -------
с текущей сизифовской тоже глючит, но чуть по-другому ;)

может стоит посмотреть из чего убунтушники собрали?
------- Comment #7 From 2007-10-23 15:18:14 -------
То, что показал Вам человек -- собирали не убунтушники.

Собирал сам человек.

Кстати, текущая сизифовская, установленная на 4.0/branch дефектов никаких не
показывает.
------- Comment #8 From 2007-10-23 15:35:08 -------
может я конечно что-то не то делаю, но я только что установил в 4.0 ffmpeg с
зависимостями из сизифа и выполнил ту строку что прислал человек. Получился
какой-то маленький, перекошеный кусок ролика. 
Но я не спец по ffmpeg, Вам как майнтейнеру виднее. Если с текущес сизифовской
лучше - надо, наверное, перекладывать.
------- Comment #9 From 2007-10-23 15:44:33 -------
во всяком случае у меня файл выглядит точно так же, как и wmv (с поправкой на
квадратики из-за маленького битрейта)
------- Comment #10 From 2008-09-23 20:19:44 -------
баг все еще актуален?
------- Comment #11 From 2008-09-23 20:56:40 -------
на ffmpeg-11656-alt1 (из 4.1) не проявляется, так что похоже не актуален.
------- Comment #12 From 2008-09-23 21:15:23 -------
тогда перевешу на 4.1.