Bug 13276 - GIMP requires GTK+ version 2.10.13 or later.
: GIMP requires GTK+ version 2.10.13 or later.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gimp)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-31 13:58 by
Modified: 2007-11-05 12:19 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-31 13:58:21
Нужно добавить в Requires зависимость на версию libgtk+2, иначе получаем:
GIMP requires GTK+ version 2.10.13 or later.
Installed GTK+ version is 2.10.6.
------- Comment #1 From 2007-10-31 15:10:42 -------
если будет макрос по типу
kdelibs >= %{get_version kdelibs}
добавлю
------- Comment #2 From 2007-11-01 16:20:05 -------
2 ktirf: так что там думали про GNOME 2.20 в бранче?
------- Comment #3 From 2007-11-01 16:40:22 -------
Ну, он будет :) Но сначала нужно разобраться с багой в поддержке клавиатуры,
из-за которой выводится пресловутое окошко про невозможность изменить параметры
Xkb.
Насчёт макроса - я не очень понимаю, какой макрос хочется, предпочёл бы
обойтись
без него. Чем GTK+ 2.10.13 отличается от более старых, почему GIMP хочет именно
его?
------- Comment #4 From 2007-11-01 17:48:33 -------
макрос который будет выдавать версию libgtk+2 с которой собирались, типа:
rpmquery --queryformat="%{version}\n" libgtk+2
почему gimp, gtk2-themes-qtcurve и пр. собранные с libgtk+2-2.12.1 требуют 
GTK+ version 2.10.13 or later понятия не имею
------- Comment #5 From 2007-11-03 18:59:35 -------
gimp-2.4.1-alt1
Requires: libgtk+2 >= %(rpmquery --queryformat=%%{version} libgtk+2)