Bug 13516 - Требует пакеты seamonkey и не признает firefox
: Требует пакеты seamonkey и не признает firefox
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gxine)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
: 13520
:
  Show dependency tree
 
Reported: 2007-11-23 22:21 by
Modified: 2008-02-12 20:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-11-23 22:21:43
Нельзя ли сделать пакет gxine и его плагина совместимыми не только с seamonkey,
но и с firefox?
------- Comment #1 From 2007-11-23 22:39:27 -------
Можно. Но только или-или: на этапе сборки можно указать какие библиотеки 
использовать: firefox или seamonkey.
Думаю, этовсё в продолжении старой темы: вынести мозилловские библиотеки как 
shared и собирать всё мозилье семейство с ними, чтоб они не таскали каждый 
свою.
Есть ещё вариант собрать с libjs, но когда я месяц-два назад смотрел неё в 
Сизифе, она была у нас в ужастном неюзабельном состоянии :(
------- Comment #2 From 2007-11-24 22:20:40 -------
Может тогда собирать оба варианта? 
------- Comment #3 From 2007-11-25 06:41:49 -------
(In reply to comment #2)

Поковырялся и выяснил, что теоретически можно собрать с маленькой (<1М пакет) 
независимой библиотекой libjs.
Можно и практически, но придётся городить костыли, потому как:
1) почему-то пакет, содержащий в себе libjs.so называется libmozjs и libjs даже 
не провайдит;
2) почему-то хэдеры находятся в /usr/include/mozjs/, а не в /usr/include/js/;
3) почему-то в пакете -devel находится libjs.a, хотя должны находится 
в -devel-static.
Можете задать мейнтейнеру эти вопросы:)

> Может тогда собирать оба варианта? 

Два варианта, отличающиеся несколькими байтами в файле /usr/bin/gxine - это, 
конечно же, не решение:)
------- Comment #4 From 2007-11-25 06:47:49 -------
(In reply to comment #3)
Я уже повесил багу на libmozjs (#13520)
------- Comment #5 From 2008-02-12 20:36:31 -------
gxine-0.5.11-alt5 теперь требует только libjs (~350К)