Bug 13517 - Remove "authorization requests if a value specified"
: Remove "authorization requests if a value specified"
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/pidgin)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-11-24 15:59 by
Modified: 2008-01-03 22:30 (History)


Attachments
Этот патч добавляет проверку на наличие флага, установленного моим плагином. (586 bytes, patch)
2007-11-24 16:02, Yury A. Romanov
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-11-24 15:59:32
Это не баг, но все же. 
можно приложить следующий патч? он нужен для эффективной работы моего пакета
purple-plugin-bot-sentry

diff --git a/pidgin/pidgin/gtkaccount.c b/pidgin/pidgin/gtkaccount.c
index 21e14c8..093457e 100644
--- a/pidgin/pidgin/gtkaccount.c
+++ b/pidgin/pidgin/gtkaccount.c
@@ -2549,6 +2549,11 @@ pidgin_accounts_request_authorization(PurpleAccount *account,
        if (message != NULL && *message == '\0')
                message = NULL;

+       if(purple_prefs_get_bool("/plugins/core/block_authorization_requests"))
+           {
+           return NULL;
+           };
+
        buffer = g_strdup_printf(_("%s%s%s%s wants to add %s to his or her buddy
list%s%s"),
                                remote_user,
                                (alias != NULL ? " ("  : ""),


Actual Results:  
Ну я думаю понятно

Expected Results:  
Ну я думаю понятно
------- Comment #1 From 2007-11-24 16:02:28 -------
Created an attachment (id=2287) [details]
Этот патч добавляет проверку на наличие флага, установленного моим плагином.

Этот патч добавляет проверку на наличие флага, установленного моим плагином. В
случае, если он установлен, запросы авторизации не отображаются, если нет -
отображаются. Сделано это в целях борьбы с ойсековым спамом, рассылаемым внутри
запросов авторизации.
------- Comment #2 From 2007-12-17 12:06:40 -------
в pidgin 2.3.x это патч не нужен? правильно?
------- Comment #3 From 2007-12-17 12:40:08 -------
(In reply to comment #2)
> в pidgin 2.3.x это патч не нужен? правильно?

Правильно. Там были добавлены сигналы "account-authorization-requested",
"account-authorization-granted" и "account-authorization-denied" но при попытке
модуля реагировать на них, pidgin падает. Может, конечно, я что-то не так пишу...