Bug 13814 - too broad subpackage dependencies
: too broad subpackage dependencies
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libao)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-12-27 16:46 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-12-27 16:46:53
А с чего это:

- libao-pulse тащит полсизифа на букву "pulse";
- libao тащит libao-oss?
------- Comment #1 From 2007-12-29 18:59:50 -------
(In reply to comment #0)
> А с чего это:
> 
> - libao-pulse тащит полсизифа на букву "pulse";

1) pulse у нас в Сизифе не рабочий. 
2) libao-pulse висит на nobody@. 
3) пинать надо маинтейнера pulseaudio.

> - libao тащит libao-oss?

Для обратной совместимости. Пришло время убрать?
------- Comment #2 From 2008-06-14 18:32:07 -------
Невижу никаких предложений что делать и как.
------- Comment #3 From 2008-06-14 20:01:05 -------
(In reply to comment #2)
> Невижу никаких предложений что делать и как.

Убрать зависимость из libao-pulse:
pulseaudio >= 0.9.2

по libao-oss: он "весит" 7.5К и ничего кроме libc не требует. Так что ИМХО
практически не мешает.

2mike: может перевести багу в "Серьёзность: trivial"?
------- Comment #4 From 2008-06-14 20:04:27 -------
(In reply to comment #3)
> Убрать зависимость из libao-pulse:
> pulseaudio >= 0.9.2

...или заменить на
Requires: libpulseaudio >= 0.9.2
------- Comment #5 From 2008-06-14 22:35:06 -------
Ну давай.

PS: я как-то наведывался в эту багу и вроде что-то писал, но явно отвлёкся до
пинка в Commit :(
------- Comment #6 From 2008-06-15 16:12:33 -------
(In reply to comment #4)
> (In reply to comment #3)
> > Убрать зависимость из libao-pulse:
> > pulseaudio >= 0.9.2
> 
> ...или заменить на
> Requires: libpulseaudio >= 0.9.2

Так и сделаю.
------- Comment #7 From 2008-06-15 16:28:37 -------
fixed in libao-pulse-0.9.3-alt2.src.rpm