Bug 13895 - after changing the screen dimensions, the bottom panel hangs at the middle of the screen
: after changing the screen dimensions, the bottom panel hangs at the middle of...
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/gnome-panel)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-06 11:10 by
Modified: 2014-12-24 15:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-06 11:10:29
gnome-panel-2.20.2-alt2


Steps to Reproduce:
1. I have been using Gnome and had a panel at the bottom (non-expanded, i.e.,
with variable size; and auto-hiding).
2. I changed the size of the screen from 1024x768 to 1280x1024, started Gnome.

Actual Results:  
Now, when I start Gnome, the panel is not at the bottom, but probably at the old
coordinates. (The top, left and right panels are OK.)

It can be placed to the correct position by playing with its Properties: turning
on "Expand" expands it and sets to the bottom (the correct position), and then I
have to turn "Expand" off again, so that it has variable size. After that it
remains at the bottom.

But this new state is not "saved": when start Gnome another time, the panel is
again in the middle of the screen.
------- Comment #1 From 2008-01-06 19:02:52 -------
Most likely it's an upstream bug. shaba@, if you have a wish and time, please
look at this.
------- Comment #2 From 2008-03-25 03:50:51 -------
Workaround: either 
1) make it "expanded" (then it is attached to the bottom) 
2) or set /apps/panel/toplevels/bottom_panel/y to a crazy big value (I just
added a zero: 5110; in gconf-editor;  I also removed
/apps/panel/toplevels/bottom_panel/y_bottom because it had no documentation),
then it is at the bottom.

Probably the problem is that the bottom panel's coordinate is not given
relatively to the bottom, but absolutely, so when changing the dimensions it
gets messed up. (I wonder why does it not happen with the right panel though?..
My right panel was OK.) 
------- Comment #3 From 2008-03-25 03:53:27 -------
This applies to gnome-panel-2.22.0-alt1.1 also (I updated it in hope to get this
fixed; then, when nothing changed, I started doing the tweaks in gconf-editor).
------- Comment #4 From 2008-05-30 16:54:50 -------
in roadmap gnome-2.24:

GNOME Panel

    * Positioning fixes of applets when Panel size changes
------- Comment #5 From 2008-06-01 15:16:23 -------
(In reply to comment #4)
> in roadmap gnome-2.24:
> 
> GNOME Panel
> 
>     * Positioning fixes of applets when Panel size changes

That doesn't seem to be directly related to this bug which I used to experience:
"my" bug had nothing to do with the positions of applets, it was about the
position of the panel in the screen after changing the dimension of the screen.

BTW, I'm not sure I will be able to test a fix (if it will be released at some
moment) because I have already cleaned my panel configuration with gconf-editor
(I'm sorry, it was unbearable to have the panel in the middle of the desktop).
------- Comment #6 From 2008-06-01 15:28:47 -------
No, I'm not correct.

(In reply to comment #5)

> BTW, I'm not sure I will be able to test a fix (if it will be released at some
> moment) because I have already cleaned my panel configuration with gconf-editor
> (I'm sorry, it was unbearable to have the panel in the middle of the desktop).

It's possible to test this: one should set small X dimensions, start Gnome under
a fresh user, set up panels there, then change the X dimensions to larger
values, and start Gnome under that user once more. Ok, I'll do this check for
the current gnome-panel a bit later.
------- Comment #7 From 2011-01-22 16:57:01 -------
(In reply to comment #4)
> in roadmap gnome-2.24:
> GNOME Panel
>     * Positioning fixes of applets when Panel size changes
So is it broken yet for gnome-panel-2.32.1-alt1?
------- Comment #8 From 2014-12-24 15:02:16 -------
Check this against MATE or GNOME3 (classic mode) probably, and change the
resolution appropriately.  This one has timed out clearly.