Bug 13898 - Новые сборки перестали запускаться на картах Nvidia старее GeForce Ti
: Новые сборки перестали запускаться на картах Nvidia старее GeForce Ti
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/xorg-x11-server)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-06 14:22 by
Modified: 2008-01-20 03:21 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-06 14:22:08
У меня имеется Pentium III c Nvidia GeForce 440MX AGP2x. Более новые видеокарты
в эту машину поставить невозможно и нецелесообразно. Последний драйвер Nvidia
для этой видеокарты - 9643. С ним успешно работал beryl. 

После обновления xorg до xorg-x11-server-1.4.0.90-alt1 перестал действовать
параметр -ignoreABI и все система развалилась. Машина является типичным
десктопом и часто используется для показа, сканирования и редактирования
фотографий. Обновление было связано с допекавшими пользователей багами и
случайно потянуло за собой новый xorg.

Выходит, что нужно иметь второй совместимый xorg, т.к. ждать от Nvidia нового
ABI для старых уже карт бесполезно... 
Steps to Reproduce:
1.Обновить Сизиф на Pentium III c Nvidia GeForce 440MX
Actual Results:  
Нет больше Х-ов, не работает GNOME и beryl (из-за отсутствия 3D драйверов)
------- Comment #1 From 2008-01-06 15:14:40 -------
по вопросам работы/неработы проприетарных драйверов обращайтесь к 
производителю
------- Comment #2 From 2008-01-06 16:40:27 -------
Замечу, что баг не FIXED, и закрыть его надо по-другому.
------- Comment #3 From 2008-01-06 16:43:17 -------
ок
------- Comment #4 From 2008-01-06 16:44:00 -------
инвалид с большой буквы
------- Comment #5 From 2008-01-07 10:39:15 -------
(In reply to comment #2)
> Замечу, что баг не FIXED, и закрыть его надо по-другому.

Лучше перевесить на соответствующий пакет.
------- Comment #6 From 2008-01-16 21:12:59 -------
Это как-раз соответствующий пакет. Посколькупроизводитель -козлы, и исправления
не будет до появления альтернативного 3D драйвера (очень сомнительно), то для
работы новых дистрибутивов, где libGL требуется для отрисовки даже без compiz
на
видеокартах NVIDIA TNT, MX440 и пр. очень старых моделях надо шевелиться.
------- Comment #7 From 2008-01-16 21:19:55 -------
1. -ignoreABI работет
2. для последних драйверов nvidia из сизифа ignoreABI не нужно
3. есть драйвер nv
------- Comment #8 From 2008-01-16 21:21:29 -------
и 4. если не работает драйвер nvidia, вешайте багу на драйвер nvidia
------- Comment #9 From 2008-01-17 18:04:24 -------
(In reply to comment #7)
> 2. для последних драйверов nvidia из сизифа ignoreABI не нужно
вообще ни для каких не нужно
------- Comment #10 From 2008-01-17 18:06:05 -------
Я в рассылке отвечал уже. Иди вы только пишете?
------- Comment #11 From 2008-01-20 03:21:09 -------
Последние драйвера все-равно не работают с моей старой картой. Пришлось
откатить
xorg. Обновлять эту машину дальше - опасно. перейти на драйвер nv не выйдет,
потому что не запускаются нужные программы, в том числе штатный диспетчер окон
GNOME metacity.