Bug 13902 - Проблема при обновлении
: Проблема при обновлении
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libgtksourceview1)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-06 18:11 by
Modified: 2008-01-11 11:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-06 18:11:39
На чистой системе, где стоял старый ещё libgtksourceview, обновление не 
проходит:
[root@builder ftp]# apt-get install libgtksourceview1
The following NEW packages will be installed:
  libgtksourceview1
file /usr/lib/libgtksourceview-1.0.so.0.0.0 from install of 
libgtksourceview1-1.8.5-alt3 conflicts with file from package 
libgtksourceview-1.8.5-alt1

[root@builder ftp]# apt-get install libgtksourceview2
  libgtksourceview2: Obsoletes: libgtksourceview (< 2.0.2-alt2)

При этом 
[root@builder ftp]# apt-get install libgtksourceview2 libgtksourceview1
даёт правильное решение
The following packages will be REPLACED:
  libgtksourceview (by libgtksourceview2)
The following NEW packages will be installed:
  libgtksourceview1 libgtksourceview2

Сейчас в пакетах
[lav@lav db]$ rpm --obsoletes libgtksourceview1
libgtksourceview1.8 < 1.8.5-alt3
[lav@lav db]$ rpm --obsoletes libgtksourceview2
libgtksourceview < 2.0.2-alt2


Думаю, что в libgtksourceview1 не хватает
Obsoletes: libgtksourceview < 1.8.5-alt3

[lav@lav db]$ rpm --obsoletes libgtksourceview1
libgtksourceview1.8 < 1.8.5-alt3
[lav@lav db]$ rpm --obsoletes libgtksourceview2
libgtksourceview < 2.0.2-alt2
------- Comment #1 From 2008-01-10 11:29:59 -------
добавлен 
Obsoletes: libgtksourceview < 1.8.5-alt4