Bug 1394 - %install section fails while building package
: %install section fails while building package
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/libdb3)
: unstable
: all Linux
: P4 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-10-10 19:47 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-10-10 19:47:43
+ pushd /var/tmp/libdb3-buildroot
/var/tmp/libdb3-buildroot /usr/src/RPM/BUILD/db-3.3.11
+ mv ./usr/lib/libdb-3.3.so ./usr/lib/libdb-3.so lib
+ ln -snf ../../lib/libdb-3.3.so ./usr/lib/libdb.so
+ ln -s libdb-3.3.a ./usr/lib/libdb.a
+ mv ./usr/lib/libdb_tcl-3.3.a ./usr/lib/libdb_tcl-3.3.la ./usr/lib/libdb_tcl-3.3.so
./usr/lib/libdb_tcl-3.so ./usr/lib/libdb_tcl.so ./usr/lib
mv: `./usr/lib/libdb_tcl-3.3.a\' and `./usr/lib/libdb_tcl-3.3.a\' are the same file
mv: `./usr/lib/libdb_tcl-3.3.la\' and `./usr/lib/libdb_tcl-3.3.la\' are the same file
mv: `./usr/lib/libdb_tcl-3.3.so\' and `./usr/lib/libdb_tcl-3.3.so\' are the same file
mv: `./usr/lib/libdb_tcl-3.so\' and `./usr/lib/libdb_tcl-3.so\' are the same file
mv: `./usr/lib/libdb_tcl.so\' and `./usr/lib/libdb_tcl.so\' are the same file
ошибка: Неверны  код возврата из /var/tmp/rpm-tmp.27942 (%install)
---

---

------- Comment #1 From 2002-10-10 20:07:35 -------
Похоже, что у Вас %_tcllibdir равен /usr/lib, что неверно.
Начиная с появления этого макроса в rpm, он был равен /usr/lib/tcl,
каковым и остается по сей день.
------- Comment #2 From 2002-10-10 20:07:35 -------
Похоже, что у Вас %_tcllibdir равен /usr/lib, что неверно.
Начиная с появления этого макроса в rpm, он был равен /usr/lib/tcl,
каковым и остается по сей день.
------- Comment #3 From 2002-10-10 23:50:45 -------
Unable to reproduce in current Sisyphus.
------- Comment #4 From 2002-10-10 23:50:45 -------
Unable to reproduce in current Sisyphus.