Bug 13974 - Unsafe EDITOR usage
: Unsafe EDITOR usage
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/etersoft-build-utils)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-11 15:31 by
Modified: 2008-05-29 18:35 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-11 15:31:30
В /etc/rpm/etersoft-build-functions, в строке 482 (по состоянию на версию
1.3.5-alt2) имеется конструкция [ -z $EDITOR ], которая при пустом $EDITOR
приводит к ошибке. Требуется добавить кавычки: [ -z "$EDITOR" ]
------- Comment #1 From 2008-01-12 04:38:07 -------
Спасибо, исправил. Будет в 1.4.0-alt1
А EDITOR пустой у тебя отсутствует штатно в системе?
------- Comment #2 From 2008-01-12 09:02:33 -------
Нет :) На самом деле у меня гораздо более плохой вариант вылез: EDITOR="vim
-o".
К чему приводит помещение этого текста без кавычек в аргументы test, я думаю,
ты
догадаешься. В общем, оно вот именно что unsafe.
------- Comment #3 From 2008-01-12 11:43:09 -------
Да, конечно. Я просто поинтересовался :)