Bug 14039 - Невозможно копирование из архива в директорию в кирилице
: Невозможно копирование из архива в директорию в кирилице
Status: CLOSED FIXED
: Branch 4.0
(All bugs in Branch 4.0/krusader)
: 4.0
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-16 19:20 by
Modified: 2008-10-30 17:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-16 19:20:44
Дистрибутив: ALT4.0 branch
Версия: krusader-1.80.0-alt1

Замечено при входе в архив любого типа и попытке скопировать его содержимого в 
директорию в кирилице, например в директорию: /home/roman/Тест.
Сообщение об ошибке такое: "Не удаётся записать в 
файл /home/roman/Тест/test.txt"
------- Comment #1 From 2008-03-27 11:04:04 -------
В версии 1.90.0 это исправлино. Чего её досих пор нет в Сизифе?
------- Comment #2 From 2008-03-27 11:34:12 -------
потому что когда я последний раз смотрел, её не было в природе : 

2008-03-15 14:47 krusader-1.90.0.tar.gz
------- Comment #3 From 2008-09-21 15:59:50 -------
Проблема замечена и на 1.90.
------- Comment #4 From 2008-10-02 18:30:02 -------
Да. Ошибка. Попробовал запостить багу в апстрим. Посмотрим..
------- Comment #5 From 2008-10-23 02:36:38 -------
Дополнение: мало того, что копирование в каталог, названный кириллицей не
происходит, так ещё и те файлы, которые мы хотелы туда скопировать появляются в
корне хомяка! То есть в папке ~ пользователя, от имени которого запущен
Krusader
------- Comment #6 From 2008-10-27 13:08:33 -------
Я потестил версию 2.0.0-beta1 - там это работает. Как соберу пакет - закрою.
------- Comment #7 From 2008-10-30 17:48:42 -------
Цитирую себя из devel@ (частично)

Итак, в Сизифе уже появился пакет kde4-krusader-2.0.0-alt0.beta1.1

В КДЕ4 для запуска нужно или пользоваться меню или запускать команду krusader
В КДЕ3 по команде krusader запускается старый, версии 1.90.0, поэтому если есть
желание посмотреть на новый, то нужно запускать командой
/usr/lib/kde4bin/krusader

Поскольку в старых версиях ошибка точно уже исправлена не будет, в в версии
2.0.0-beta1 она исправлена, то что багу резолвлю с решением FIXED.