Bug 14364 - VE localization suffers
: VE localization suffers
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/alterator-ovz)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-08 16:32 by
Modified: 2009-07-20 18:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-08 16:32:29
Для более-менее обжитого, а не минимального шаблона VE (это который начинается
не с basesystem, а с interactivesystem) также требуется добавлять пакеты iconv
и
glibc-gconv-modules; хорошо бы придумать, как либо забирать из HN
/etc/rpm/macros по части %_install_langs, либо указывать руками (но это было бы
осмысленно как-то с alterator-i18n скручивать?).

Характерный признак -- странное поведение разных программ в разных локалях
(Миша, попроси fisher@ детали вкатить?).
------- Comment #1 From 2008-02-08 16:32:57 -------
reassign
------- Comment #2 From 2008-02-08 16:38:47 -------
Кстати!  А мож эти зависимости просятся в interactivesystem? :)
------- Comment #3 From 2008-02-10 14:08:23 -------
(In reply to comment #0)

> Характерный признак -- странное поведение разных программ в разных локалях
> (Миша, попроси fisher@ детали вкатить?).

Да я и сам помню, внешнее проявление было таким:

При выставлении LANG=uk_UA.UTF-8 запуск vim приводил к выводу стартового
сообщения в виде "крокозябр". Хотя, с ru_RU.UTF-8 все проходило успешно.

Установка glibc-gconv-modules все вылечила.
------- Comment #4 From 2009-07-20 18:32:21 -------
Пакета больше нет, на всякий добавляю майнтейнера alterator-mkve в копию.