Bug 14392 - Собранный из svn django не работает
: Собранный из svn django не работает
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/python-module-django)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-11 21:14 by
Modified: 2009-05-13 07:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-11 21:14:58
Создаю новый сайт, так как описано у них в туториале. Добавляю админский 
интерфейс, тоже по нему. Не могу войти и поадминить. С версией из бранча все 
работает как надо.
------- Comment #1 From 2008-06-13 13:00:39 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #2 From 2008-07-05 11:13:20 -------
не моё
------- Comment #3 From 2008-07-06 03:26:38 -------
Подробнее, пожалуйста.
------- Comment #4 From 2008-07-11 23:35:39 -------
Добавлю сюда же свои пять копеек.

samurai@home ~/django/fondnew $ python manage.py runserver
Validating models...
Unhandled exception in thread started by <function inner_run at 0x2b3fd41ab050>
Traceback (most recent call last):
  File
"/usr/lib/python2.5/site-packages/django/core/management/commands/runserver.py",
line 47, in inner_run
    self.validate(display_num_errors=True)
  File "/usr/lib/python2.5/site-packages/django/core/management/base.py", line
112, in validate
    num_errors = get_validation_errors(s, app)
  File "/usr/lib/python2.5/site-packages/django/core/management/validation.py",
line 22, in get_validation_errors
    from django.db import models, connection
  File "/usr/lib/python2.5/site-packages/django/db/__init__.py", line 24, in
<module>
    backend = __import__('%s.base' % settings.DATABASE_ENGINE, {}, {}, [''])
ImportError: No module named postgresql_psycopg2.base


естественно:
samurai@home ~/django/fondnew $ rpm -qa G psycopg
python-module-django-dbbackend-psycopg2-0.97-alt1.svn7540
python-module-psycopg-1.1.21-alt2.1
python-module-django-dbbackend-psycopg-0.97-alt1.svn7540
python-module-psycopg2-2.0.6-alt3.1

если изменить в settings на postgresql (т.е. модуль psycopg) то работает.
Не уверен что это django, может быть это python-module-psycopg-1.1.21-alt2.1
------- Comment #5 From 2008-08-07 03:07:05 -------
Проверьте, пожалуйста, с текущей версией django (1.0 alpha)
------- Comment #6 From 2008-08-07 10:01:29 -------
(In reply to comment #1)
> *** This bug has been confirmed by popular vote. ***
> 

А как админку добавляете?

насчет psycopg2 модуля - треба обновлять саму psycopg2  в сизифе. Это не
джанговская проблема.
------- Comment #7 From 2009-05-13 07:46:31 -------
давно исправлено