Bug 14596 - unmet dependencies
: unmet dependencies
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gutenpy)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-20 22:30 by
Modified: 2008-04-07 15:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-20 22:30:26
apt> install gutenpy 
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gutenpy: Depends: /usr/bin/python2.4 but it is not installable
E: Broken packages
apt> showpkg gutenpy 
Package: gutenpy
Versions: 
0.3.0-alt2.1(/var/lib/apt/lists/ftp.altlinux.org_pub_distributions_ALTLinux_Sisyphus_i586_base_pkglist.classic)(/var/lib/apt/lists/ftp.linux.kiev.ua_pub_Linux_ALT_Sisyphus_i586_base_pkglist.classic)

Reverse Depends: 
Dependencies: 
0.3.0-alt2.1 - /usr/bin/python2.4 (0 (null)) python2.5(bz2) (0 (null))
python2.5(cPickle) (0 (null)) python2.5(gobject) (0 (null)) python2.5(gtk) (0
(null)) python2.5(gzip) (0 (null)) python2.5(os) (0 (null)) python2.5(pango) (0
(null)) python2.5(platform) (0 (null)) python2.5(re) (0 (null))
python2.5(socket) (0 (null)) python2.5(string) (0 (null)) python2.5(tempfile) (0
(null)) python2.5(urllib) (0 (null)) python2.5(webbrowser) (0 (null))
python2.5(xml) (0 (null)) python2.5(zipfile) (0 (null)) sh (0 (null)) 
Provides: 
0.3.0-alt2.1 - python2.5(GutenPy.widgets) python2.5(GutenPy.rdfparse)
python2.5(GutenPy.gutenpy) python2.5(GutenPy.dictclient)
python2.5(GutenPy.charset_widget) python2.5(GutenPy.catalog)
python2.5(GutenPy.bookmarks) python2.5(GutenPy) 
Reverse Provides: 
apt>
------- Comment #1 From 2008-02-22 20:58:20 -------
Пересобрано под новый Python, 0.3.0-alt3
------- Comment #2 From 2008-03-25 20:12:59 -------
apt> showpkg gutenpy
Package: gutenpy
Versions: 
0.3.0-alt3(/var/lib/apt/lists/ftp.altlinux.org_pub_distributions_ALTLinux_Sisyphus_i586_base_pkglist.classic)(/var/lib/apt/lists/ftp.linux.kiev.ua_pub_Linux_ALT_Sisyphus_i586_base_pkglist.classic)

Reverse Depends: 
Dependencies: 
0.3.0-alt3 - /usr/bin/python2.4 (0 (null)) python2.5(bz2) (0 (null))
python2.5(cPickle) (0 (null)) python2.5(gobject) (0 (null)) python2.5(gtk) (0
(null)) python2.5(gzip) (0 (null)) python2.5(os) (0 (null)) python2.5(pango) (0
(null)) python2.5(platform) (0 (null)) python2.5(re) (0 (null))
python2.5(socket) (0 (null)) python2.5(string) (0 (null)) python2.5(tempfile) (0
(null)) python2.5(urllib) (0 (null)) python2.5(webbrowser) (0 (null))
python2.5(xml) (0 (null)) python2.5(zipfile) (0 (null)) sh (0 (null)) 
Provides: 
0.3.0-alt3 - python2.5(GutenPy.widgets) python2.5(GutenPy.rdfparse)
python2.5(GutenPy.gutenpy) python2.5(GutenPy.dictclient)
python2.5(GutenPy.charset_widget) python2.5(GutenPy.catalog)
python2.5(GutenPy.bookmarks) python2.5(GutenPy) 
Reverse Provides: 
apt> install gutenpy
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gutenpy: Depends: /usr/bin/python2.4 but it is not installable
E: Broken packages
apt> 
------- Comment #3 From 2008-04-07 15:16:33 -------
Oops, оно в upstream'е ещё и в виде '#!/usr/bin/python2.4' прибито было.
Оторвано в 0.3.0-alt4