Bug 14606 - doesn't work in most terminals
: doesn't work in most terminals
Status: CLOSED DUPLICATE of bug 9273
: Sisyphus
(All bugs in Sisyphus/bash-completion)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
: 14604 14605
  Show dependency tree
 
Reported: 2008-02-21 16:48 by
Modified: 2008-02-22 13:38 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-21 16:48:27
bash-completion-20060301-alt04
bash-3.1.17-alt4

It doesn't work in:
aterm-1.0.1-alt1
xterm-232-alt1
konsole (kdebase-3.5.8-alt12)
gnome-terminal-2.18.4-alt1

It works in Eterm-0.9.3-alt2 and in the linux console (2.6.24-std-def-alt2).
Steps to Reproduce:
1. Start xterm
2. type: rpm -q pyth<TAB><TAB><TAB>
3.
Actual Results:  
no completion suggestions

Expected Results:  
there are completion suggestions. It works in Eterm-0.9.3-alt2:

$ rpm -q python
python                              python-module-mutagen              
python-module-pygtksourceview
python-base                         python-module-notify               
python-module-pyorbit
python-dev                          python-module-Numeric              
python-module-PyQt4
pythonlib                           python-module-numpy                
python-module-pyxdg
python-module-alsaaudio             python-module-paramiko             
python-module-PyXML
python-module-avahi                 python-module-pyao                 
python-module-qt
python-module-configparse           python-module-pycairo              
python-module-Reportlab
python-module-Crypto                python-module-pygnome              
python-modules
python-module-ctypes                python-module-pygnome-applet       
python-modules-bsddb
python-module-dbus                  python-module-pygnome-bonobo       
python-modules-compiler
python-module-elementtree           python-module-pygnome-canvas       
python-modules-curses
python-module-eyeD3                 python-module-pygnome-desktop      
python-modules-email
python-module-feedparser            python-module-pygnome-extras       
python-modules-encodings
python-module-gnome-menus           python-module-pygnome-gconf        
python-modules-gpod
python-module-gst                   python-module-pygnome-gnomeprint   
python-modules-hotshot
python-module-id3-py                python-module-pygnome-gnome-vfs    
python-module-sip
python-module-imaging               python-module-pygnome-nautilusburn 
python-modules-logging
python-module-libxml2               python-module-pygobject            
python-modules-tkinter
python-module-lxml                  python-module-pygobject-devel      
python-modules-xml
python-module-medusa                python-module-pygtk                
python-module-vte
python-module-minihallib            python-module-pygtk-devel          
python-strict
python-module-mm                    python-module-pygtk-libglade       
python-tools-i18n
$ rpm -q python
------- Comment #1 From 2008-02-21 20:58:14 -------
It doesn't work in the bash in the terminal. But it works in another bash
started as `bash --login' inside the initial bash in the terminal.
------- Comment #2 From 2008-02-21 23:17:11 -------
man bash, INVOCATION.  /etc/profile is not sourced for non-login shell.
------- Comment #3 From 2008-02-22 01:02:57 -------
I see.
Then a new question: Is Eterm wrong in that it starts a login shell (apparently)?

*** This bug has been marked as a duplicate of 9273 ***
------- Comment #4 From 2008-02-22 01:56:30 -------
(In reply to comment #3)
> Then a new question: Is Eterm wrong in that it starts a login shell (apparently)?

https://bugzilla.altlinux.org/show_bug.cgi?id=14612