Bug 14650 - Избыточные (неправильные) зависимости
: Избыточные (неправильные) зависимости
Status: CLOSED WONTFIX
: Branch 4.0
(All bugs in Branch 4.0/ghostscript)
: 4.0
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-25 21:54 by
Modified: 2014-11-05 20:15 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-25 21:54:27
Система - office-server, нацеленный на Branch 4.0. Никакой графики, ничего 
лишнего. При попытке установить ghostscript (скажем, для поднятия 
принт-сервера) получаю вот такое:
=================================
# apt-get install ghostscript
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  bwidget c2050 c2070 cjet cups epsoneplijs foo2zjs foomatic-db 
foomatic-db-engine foomatic-filters ghostscript-cups
  gutenprint gutenprint-foomatic hplip-common hplip-foomatic hplip-hpijs 
libXdamage libXxf86vm libatk libcairo libdirectfb
  libdrm libglitz libgtk+2 libgtk+2-common libgutenprint libieee1284 libijs 
libjasper libjbig libmesa libnet-snmp libnspr
  libnss libpango libxml2 lz11-V2 m2300w min12xxw mpage ncompress netpbm 
nss-utils pbm2l2030 pbm2l7k pbm2lwxl pentaxpj
  perl-Encode pnm2ppa ppmtomd printer-drivers-base printer-testpages psutils 
ptouch-driver shared-mime-info sharutils splix
  xml-common
The following NEW packages will be installed:
  bwidget c2050 c2070 cjet cups epsoneplijs foo2zjs foomatic-db 
foomatic-db-engine foomatic-filters ghostscript
  ghostscript-cups gutenprint gutenprint-foomatic hplip-common hplip-foomatic 
hplip-hpijs libXdamage libXxf86vm libatk
  libcairo libdirectfb libdrm libglitz libgtk+2 libgtk+2-common libgutenprint 
libieee1284 libijs libjasper libjbig libmesa
  libnet-snmp libnspr libnss libpango libxml2 lz11-V2 m2300w min12xxw mpage 
ncompress netpbm nss-utils pbm2l2030 pbm2l7k
  pbm2lwxl pentaxpj perl-Encode pnm2ppa ppmtomd printer-drivers-base 
printer-testpages psutils ptouch-driver
  shared-mime-info sharutils splix xml-common
0 upgraded, 59 newly installed, 0 removed and 0 not upgraded.
Need to get 47.0MB of archives.
After unpacking 245MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
=================================
Это слишком!
------- Comment #1 From 2008-02-25 23:37:09 -------
Ну... да, есть лишние зависимости.
------- Comment #2 From 2014-11-05 20:15:56 -------
В 4.0/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.