Bug 14678 - Неточность в спеке?
: Неточность в спеке?
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/claws-mail-plugin-gtkhtml2)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-27 20:45 by
Modified: 2008-02-27 22:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-27 20:45:37
Пересобирал claws-mail3 и сопутствующие для ALD Lite 4 ( а по сути уже Бранча 
4). Понятно, что по лиценз. причинам плагин вынесен за рамки самого почтовика 
из-за gpl3. Но не суть. Для пересборки потребовался gettext не ниже 0.15 
версии. В то время как такой в Сизифе не наблюдается. Я сразу не разглядел, 
скачал кучу пакетов для сборки нового (как мне казалось) gettext, а он оказался 
той же версии, что и в Бранче 4. Ну я подправил в спеке - вместо требуемого 
gettext не ниже 0.15 написал 0.14 и так собрал этот claws-mail-plugin-
gtkhtml2.. Ошибка? Или в предверии gettext 0.15? А как же тогда собирали для 
Сизифа?..
------- Comment #1 From 2008-02-27 22:31:12 -------
*** Bug 14679 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2008-02-27 22:47:07 -------
На sisyphus.ru показываются версии пакета в разных репозиториях:
http://sisyphus.ru/srpm/gettext
К сожалению, для сборки в текущем бранче (а равно и во всех дистрибутивах на
его
базе) действительно придётся заменить требуемую версию gettext (не только в
спекфайле, но и в configure.in, если я ничего не путаю). Сборка это
безболезненно переживает.
Не думаю, кстати, что плагин вынесен из почтовика из-за лицензии. Просто
исторически Claws-Mail комплектовался другим плагином для просмотра HTML, на
базе Dillo.