Bug 1470 - incomplete Requires: freetype2 version
: incomplete Requires: freetype2 version
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/fontconfig)
: unstable
: all Linux
: P5 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-10-26 00:48 by
Modified: 2009-05-10 09:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-10-26 00:48:10
freetype2-2.0.4-alt1 was installed. After fontconfig-2.0-alt8 was installed on
this system, it didn\'t work: fc-cache reported something concerning
\'Relocation error\'.

After upgrading freetype2 to 2.1.2-alt2, it started working.

---

---
------- Comment #1 From 2003-09-20 16:00:36 -------
Проблема остается и на fontconfig-2.2.1-alt2.
------- Comment #2 From 2004-05-24 15:10:23 -------
на мантейнера 
------- Comment #3 From 2006-09-27 21:42:45 -------
В текущем (2.3.2-alt8) не наблюдаю ручных Requires; пакет хочет
libfreetype.so.6. Проблем с fc-cache тоже не наблюдаю.

De facto fixed?
------- Comment #4 From 2006-09-27 21:47:16 -------
Наверно. Уж и не помню такого бага.
------- Comment #5 From 2007-08-14 16:32:53 -------
Во freetype и fontconfig уже добавлен versioning, т.е. не должно такое 
воспроизводиться
------- Comment #6 From 2008-08-15 22:24:50 -------
Да, хоть в наборе зависимостей как будто ничего не поменялось (всё та же
libfreetype.so.6), теперь той ошибки нет даже с достаточно старой версией
freetype2 (возможно, конечно, плохой был именно выпуск freetype2-2.0.4-alt1, а
более ранние были хорошие, но сейчас уж это в прошлом).

# strace -fF -e trace=file fc-cache 2>&1 | fgrep -i freetype
open("/usr/lib/libfreetype.so.6", O_RDONLY) = 3
# rpm -q fontconfig        
fontconfig-2.6.0-alt1
# rpm -qf /usr/lib/libfreetype.so.6
freetype2-2.0.3-alt1
# 

Закрою.