Bug 14726 - Requires hwinfo
: Requires hwinfo
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libapr1-devel)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-01 17:30 by
Modified: 2008-10-21 19:12 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-01 17:30:56
hwinfo   нужен для libapr1-devel-1.2.8-alt1.2.1
Очевидно, из-за /usr/share/apr-1/build/config.guess (getsysinfo). См., 
например, automake_1.10 на предмет фикса.
------- Comment #1 From 2008-03-29 19:16:04 -------
Что-нибудь вроде
%add_findreq_skiplist %_datadir/apr-1/build/config.guess
------- Comment #2 From 2008-03-29 19:18:27 -------
Данная зависимость раздувает требования всех apr-зависимых приложений (типа
php), делая их совершенно бредовыми:

reparing packages for installation...
rpm-build-php5-5.2.5-alt1
Preparing packages for installation...
libpam0-devel-0.99.10.0-alt1
ca-certificates-2007.02.06-alt1
dmidecode-2.9-alt1
dmsetup-1.02.24-alt1
hal-info-20080310-alt1
hwdatabase-0.3.25-alt1
libdbus-1.1.20-alt1
libexpat-2.0.1-alt0.1
dbus-1.1.20-alt1
libhal-0.5.10-alt11
libvolume_id-108-alt2
udev_static-addon-0.1-alt1
udev-108-alt2
libdbus-glib-0.74-alt2
libusb-0.1.12-alt1.0
hal-0.5.10-alt11
hwinfo-13.57-alt1
libssl6-0.9.8d-alt4
libssl-devel-0.9.8d-alt4
php-base-2.2-alt1
libmm-1.4.2-alt1
xml-common-0.6.3-alt11
libxml2-2.6.31-alt1.1
shtool-2.0.2-alt1
php5-libs-5.2.5-alt1
zlib-devel-1.2.3-alt4
php5-devel-5.2.5-alt1
------- Comment #3 From 2008-03-29 23:58:11 -------
Данный костыль точно помог php5.
------- Comment #4 From 2008-10-21 16:40:00 -------
Кажется, исправлено в 1.2.12-alt2