Bug 14809 - doesn't play youtube movies
: doesn't play youtube movies
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mozilla-plugin-gnash)
: unstable
: all Linux
: P2 major
Assigned To:
:
: http://www.youtube.com/v/3UgpfSp2t6k
:
:
:
  Show dependency tree
 
Reported: 2008-03-07 18:07 by
Modified: 2012-01-19 14:35 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-07 18:07:00
gnash-0.8.1-alt1
libgnash-0.8.1-alt1
mozilla-plugin-gnash-0.8.1-alt1

epiphany-2.20.3-alt1.1
Steps to Reproduce:
1.epiphany http://www.youtube.com/v/3UgpfSp2t6k
2.
3.
Actual Results:  
The window is blank. Messages to the terminal:

xEmbed supported in this Mozilla version
Gtk2+ supported in this Mozilla version
NewStream: The full URL is
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
Closed 23files.
Starting process: /usr/bin/gtk-gnash -v -x 62914770 -j 1274 -k 872 -u
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
-U
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
-P height=100% -P name=plugin -P
src=http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
-P type=application/x-shockwave-flash -P width=100% - 
Forked sucessfully, child process PID is 10877
10877] 18:02:20: Verbose output turned on
10877] 18:02:20: Setting width to 1274
10877] 18:02:20: Setting height to 872
10877] 18:02:20: Setting root URL to
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
10877] 18:02:20: Setting base URL to
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
10877] 18:02:20: No rendering flags specified, using rcfile
10877] 18:02:20: Your X server expects RGB24 pixmap data for standard mode.
10877] 18:02:20: Created XEmbedded window
10877] 18:02:20: ERROR: Couldn't find pixmap file: GnashG.png

** (gtk-gnash:10877): WARNING **: Couldn't find pixmap file: GnashG.png
10877] 18:02:20: framebuffer pixel format is RGB24
10877] 18:02:20: Base url set to:
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskLSTvBIhnTSgXwlS52CEt84
10877] 18:02:20: ERROR: Unimplemented: SWF8 is not fully supported, trying
anyway but don't expect it to work
10877] 18:02:20: GTK-AGG: 3360000 bytes offscreen buffer allocated

10877] 18:02:20: initialized AGG buffer <0xb6013008>, 3360000 bytes, 1274x872,
rowsize is 3822 bytes
10877] 18:02:20: ERROR: Unimplemented: gnash::as_value
gnash::system_security_allowdomain(const gnash::fn_call&)
10877] 18:02:20: SECURITY: Load from host www.youtube.com granted (default).
10877] 18:02:21: ERROR: Unimplemented: SWF8 is not fully supported, trying
anyway but don't expect it to work
10877] 18:02:21: Movie http://www.youtube.com/swf/cps.swf (SWF8) added to library
10877] 18:02:21: ERROR: Unimplemented: FileAttributes tag in the SWF requests
that network access is not granted to this movie (or application?). Anyway Gnash
won't care; use white/black listing in your .gnashrc instead
10877] 18:02:21: ERROR: Unimplemented: METADATA tag unused: <rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"><rdf:Description
rdf:about="" xmlns:dc="http://purl.org/dc/1.1/"><dc:title>YouTube Small Embedded
Player</dc:title></rdf:Description></rdf:RDF>
10877] 18:02:21: DEBUG: gnash::mcl*
gnash::MovieClipLoader::getProgress(gnash::as_object*) enter
10877] 18:02:21: ERROR: Unimplemented: FIXME: MovieClipLoader calling
onLoadComplete *before* movie has actually been fully loaded (cheating)
10877] 18:02:21: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
10877] 18:02:21: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
10877] 18:02:21: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
10877] 18:02:21: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
10877] 18:02:21: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
10877] 18:02:21: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
10877] 18:02:21: ACTIONSCRIPT ERROR: Script aborted due to exceeded limit: Max
stack count reached (255)
10877] 18:02:21: ERROR: Unimplemented: sharedobject_getlocal
10877] 18:02:21: DEBUG: virtual gnash::MovieClipLoader::~MovieClipLoader() enter
------- Comment #1 From 2008-03-07 18:11:10 -------
The same on firefox-2.0.0.12-alt1 :

xEmbed supported in this Mozilla version
Gtk2+ supported in this Mozilla version
NewStream: The full URL is
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskJps_dkwY_mbx2yI9hsZQi0
Closed 65files.
Starting process: /usr/bin/gtk-gnash -v -x 58720960 -j 1274 -k 851 -u
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskJps_dkwY_mbx2yI9hsZQi0
-U
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskJps_dkwY_mbx2yI9hsZQi0
-P height=100% -P name=plugin -P src=about:blank -P
type=application/x-shockwave-flash -P width=100% - 
Forked sucessfully, child process PID is 11181
11181] 18:08:16: Verbose output turned on
11181] 18:08:16: Setting width to 1274
11181] 18:08:16: Setting height to 851
11181] 18:08:16: Setting root URL to
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskJps_dkwY_mbx2yI9hsZQi0
11181] 18:08:16: Setting base URL to
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskJps_dkwY_mbx2yI9hsZQi0
11181] 18:08:16: No rendering flags specified, using rcfile
11181] 18:08:16: Your X server expects RGB24 pixmap data for standard mode.
11181] 18:08:16: Created XEmbedded window
11181] 18:08:16: ERROR: Couldn't find pixmap file: GnashG.png

** (gtk-gnash:11181): WARNING **: Couldn't find pixmap file: GnashG.png
11181] 18:08:16: framebuffer pixel format is RGB24
11181] 18:08:16: Base url set to:
http://www.youtube.com/swf/l.swf?video_id=3UgpfSp2t6k&rel=1&eurl=&iurl=http%3A//i.ytimg.com/vi/3UgpfSp2t6k/default.jpg&t=OEgsToPDskJps_dkwY_mbx2yI9hsZQi0
11181] 18:08:16: ERROR: Unimplemented: SWF8 is not fully supported, trying
anyway but don't expect it to work
11181] 18:08:16: GTK-AGG: 3270000 bytes offscreen buffer allocated

11181] 18:08:16: initialized AGG buffer <0xb5f85008>, 3270000 bytes, 1274x851,
rowsize is 3822 bytes
11181] 18:08:16: ERROR: Unimplemented: gnash::as_value
gnash::system_security_allowdomain(const gnash::fn_call&)
11181] 18:08:16: SECURITY: Load from host www.youtube.com granted (default).
11181] 18:08:16: ERROR: Unimplemented: SWF8 is not fully supported, trying
anyway but don't expect it to work
11181] 18:08:16: Movie http://www.youtube.com/swf/cps.swf (SWF8) added to library
11181] 18:08:16: ERROR: Unimplemented: FileAttributes tag in the SWF requests
that network access is not granted to this movie (or application?). Anyway Gnash
won't care; use white/black listing in your .gnashrc instead
11181] 18:08:16: ERROR: Unimplemented: METADATA tag unused: <rdf:RDF
xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"><rdf:Description
rdf:about="" xmlns:dc="http://purl.org/dc/1.1/"><dc:title>YouTube Small Embedded
Player</dc:title></rdf:Description></rdf:RDF>
11181] 18:08:16: DEBUG: gnash::mcl*
gnash::MovieClipLoader::getProgress(gnash::as_object*) enter
11181] 18:08:16: ERROR: Unimplemented: FIXME: MovieClipLoader calling
onLoadComplete *before* movie has actually been fully loaded (cheating)
11181] 18:08:16: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
11181] 18:08:16: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
11181] 18:08:16: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
11181] 18:08:16: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
11181] 18:08:16: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
11181] 18:08:17: ERROR: Unimplemented: static void
gnash::SWF::SWFHandlers::ActionImplementsOp(gnash::ActionExec&)
11181] 18:08:17: ACTIONSCRIPT ERROR: Script aborted due to exceeded limit: Max
stack count reached (255)
11181] 18:08:17: ERROR: Unimplemented: sharedobject_getlocal
11181] 18:08:17: DEBUG: virtual gnash::MovieClipLoader::~MovieClipLoader() enter
11181] 18:08:17: initialized AGG buffer <0xb5f85008>, 3270000 bytes, 1x1,
rowsize is 3 bytes

11181] 18:08:41: initialized AGG buffer <0xb5f85008>, 3270000 bytes, 1274x851,
rowsize is 3822 bytes
11181] 18:09:27: ERROR: Unimplemented: gnash::as_value
gnash::system_security_allowdomain(const gnash::fn_call&)
11181] 18:09:27: Movie http://www.youtube.com/swf/cps.swf already in library
11181] 18:09:27: DEBUG: gnash::mcl*
gnash::MovieClipLoader::getProgress(gnash::as_object*) enter
11181] 18:09:27: ERROR: Unimplemented: FIXME: MovieClipLoader calling
onLoadComplete *before* movie has actually been fully loaded (cheating)
11181] 18:09:27: ACTIONSCRIPT ERROR: Script aborted due to exceeded limit: Max
stack count reached (255)
11181] 18:09:27: ACTIONSCRIPT ERROR: Script aborted due to exceeded limit: Max
stack count reached (255)
11181] 18:09:27: ACTIONSCRIPT ERROR: Script aborted due to exceeded limit: Max
stack count reached (255)
11181] 18:09:27: DEBUG: virtual gnash::MovieClipLoader::~MovieClipLoader() enter
Main loop ended, cleaning up
Any segfault past this message is likely due to improper threads cleanup.
Child process exited with status 0
------- Comment #2 From 2008-03-29 17:52:55 -------
А как в новой версии?
------- Comment #3 From 2008-09-10 21:30:36 -------
Пользуйтесь swfdec - там работает
------- Comment #4 From 2012-01-19 14:35:49 -------
mozilla-plugin-gnash-0.8.9-alt3 с firefox-9.0.1-alt1 справляются (похоже, им и
плейер подсовывают упрощённый).