Bug 14821 - cairo context error: NULL pointer
: cairo context error: NULL pointer
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/evince)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-09 06:53 by
Modified: 2008-06-19 03:18 (History)


Attachments
bookmark-cairo-NULL.pdf (5.82 KB, application/pdf)
2008-03-09 06:54, Ivan Zakharyaschev
no flags Details
bookmark-cairo-NULL.tex (151 bytes, application/x-tex)
2008-03-09 06:56, Ivan Zakharyaschev
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-09 06:53:38
evince-2.21.1-alt1
libcairo-1.4.14-alt1

The attached file produces an error message in evince. (But the program works.)

No such error message is printed in epdfview-0.1.6-alt0.1.1 or
kdegraphics-kpdf-3.5.9-alt1. (So, the error is in evince?)

The attached pdf file was generated from a LaTeX source this way:

$ latex bookmark-cairo-NULL.tex && dvipdf bookmark-cairo-NULL

(ghostscript-utils-8.60-alt1 tetex-latex-2.0-alt3)


Steps to Reproduce:
$ evince bookmark-cairo-NULL.pdf
cairo context error: NULL pointer
------- Comment #1 From 2008-03-09 06:54:42 -------
Created an attachment (id=2484) [details]
bookmark-cairo-NULL.pdf

generated by: 
latex bookmark-cairo-NULL.tex && dvipdf bookmark-cairo-NULL
------- Comment #2 From 2008-03-09 06:56:16 -------
Created an attachment (id=2485) [details]
bookmark-cairo-NULL.tex

the LaTeX source used to generate that PDF
------- Comment #3 From 2008-03-09 18:45:50 -------
libpoppler-0.6.4-alt1
------- Comment #4 From 2008-03-10 05:07:51 -------
I forgot to say that on most other PDF files (with no such bookmarks) this error
message doesn't appear.
------- Comment #5 From 2008-06-18 01:54:46 -------
Не падает.
$ rpm -q evince
evince-2.22.2-alt1

$ rpm -q libpoppler
libpoppler-0.6.4-alt2
------- Comment #6 From 2008-06-19 03:18:06 -------
(In reply to comment #5)
> Не падает.

Да, теперь нет таких сообщений об ошибках.

evince-2.22.1.1-alt2
libcairo-1.6.4-alt3

> $ rpm -q evince
> evince-2.22.2-alt1
> 
> $ rpm -q libpoppler
> libpoppler-0.6.4-alt2
>