Bug 14908 - Service sshd не стартует при первом запуске дистрибутива
: Service sshd не стартует при первом запуске дистрибутива
Status: CLOSED NOTABUG
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.0.3
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-14 15:49 by
Modified: 2008-03-19 12:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-14 15:49:30
при первом запуске дистрибутива не сгенерировались ключи ssh. В результате
сервис sshd не стартовал.

[root@test209 ~]# service sshd status
sshd is stopped
[root@test209 ~]# service sshd restart
Checking sshd configuration: sshd: Could not load host key:
/etc/openssh/ssh_host_rsa_key
sshd: Could not load host key: /etc/openssh/ssh_host_dsa_key
Disabling protocol version 2. Could not load host key
sshd: no hostkeys available -- exiting.

                                 [FAILED]
[root@test209 ~]# /etc/init.d/sshd restart
Checking sshd configuration: sshd: Could not load host key:
/etc/openssh/ssh_host_rsa_key
sshd: Could not load host key: /etc/openssh/ssh_host_dsa_key
Disabling protocol version 2. Could not load host key
sshd: no hostkeys available -- exiting.

                                 [FAILED]

[root@test209 ~]# /etc/init.d/sshd start
Generating SSH2 RSA host key:                                                  
                                 [ DONE ]
Generating SSH2 DSA host key:                                                  
                                 [ DONE ]
Generating SSH1 RSA host key:                                                  
                                 [ DONE ]
Starting sshd service:                                                         
                                 [ DONE ]
[root@test209 ~]# service sshd status
sshd is running
------- Comment #1 From 2008-03-14 17:13:04 -------
*** Bug 14909 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2008-03-14 17:13:14 -------
*** Bug 14911 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2008-03-19 12:42:00 -------
а если сразу service sshd start, а не restart?
------- Comment #4 From 2008-03-19 12:48:04 -------
Штатный способ запуска службы -- это
service sshd start