Bug 14959 - trac is broken due to changes in pysqlite2-2.4.0 (utf-8)
: trac is broken due to changes in pysqlite2-2.4.0 (utf-8)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/trac)
: unstable
: all Linux
: P1 blocker
Assigned To:
:
: http://sjohannes.wordpress.com/2007/1...
:
:
:
  Show dependency tree
 
Reported: 2008-03-18 02:13 by
Modified: 2008-03-19 13:39 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-18 02:13:27
Любая попытка запустить trac (trac-admin, trac.cgi, etc) приводит к ошибке:

ValueError: database parameter must be string or APSW Connection object

Вот описание бага в блоге разработчика trac:

http://sjohannes.wordpress.com/2007/12/05/database-parameter-must-be-string-or-apsw-connection-object/

Вот его же патч для trac:

http://trac.edgewall.org/changeset/6223

Насколько я смог проверить, после приложения этого патча все снова работает.

Steps to Reproduce:
1.trac-admin /var/lib/trac/myproject upgrade
2.
3.
Actual Results:  
Command failed: database parameter must be string or APSW Connection object

Expected Results:  
Database is up to date, no upgrade necessary.
------- Comment #1 From 2008-03-18 02:21:12 -------
2bga: Гриша, посмотри, пожалуйста.
------- Comment #2 From 2008-03-18 02:46:57 -------
Пишут, что в pysqlite-2.4.1 починили:
http://oss.itsystementwicklung.de/trac/pysqlite/wiki/2.4.1_Changelog
Проверю на днях.
------- Comment #3 From 2008-03-19 13:39:01 -------
python-module-pysqlite2-2.4.1 в Сизифе