Bug 15137 - Отсутствие пробела
: Отсутствие пробела
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/synaptic)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-28 12:57 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-28 12:57:49
rpm -qa | grep synaptic
synaptic-0.57.2-alt2.3

В диалоге внесения изменений, при нажатии на кнопку "Подробнее", видим такое:
версияamixer будет понижена
версияaplay будет понижена
alterator-users (версия 8.1-alt4) будет повышена до версии 8.2-alt1

хотя олжно быть такое:
версия amixer будет понижена
версия aplay будет понижена
alterator-users (версия 8.1-alt4) будет повышена до версии 8.2-alt1
------- Comment #1 From 2008-06-13 13:00:39 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #2 From 2009-01-10 01:01:26 -------
Если нужно, то могу и исправить, пока большие дяди заняты большими делами.
------- Comment #3 From 2009-01-10 09:58:35 -------
Если не сложно - сделайте плз... 
Кстати, пакет будет рад, если его заберет мантейнер, обладающий большим
количеством времени на поддержку ;)
------- Comment #4 From 2009-01-10 15:13:09 -------
(In reply to comment #3)
> Если не сложно - сделайте плз... 

Сделаю. Вы права на NMU только выдайте.

И это. Я тут пять раз уже перекомпилял всё, а оказалось, что я правил 
synaptic-ru.po, а он не используется и нужно было править synaptic/po/ru.po Это
что за прикол такой? Зачем было заменять po-файл, если его можно было бы просто
пропатчить?
------- Comment #5 From 2009-01-10 15:28:06 -------
(In reply to comment #4)
> И это. Я тут пять раз уже перекомпилял всё, а оказалось, что я правил 
> synaptic-ru.po, а он не используется 

Не использовался, потому что был уже готовый gmo-файл, который и
устанавливался. Наверное, кто-то полагался на то, что заменив po-файл make сам
перегенерит и gmo-файл, но этого не произошло.
------- Comment #6 From 2009-01-10 15:32:01 -------
Исправления доступны здесь:
http://git.altlinux.org/people/php_coder/packages/synaptic.git

2svd@: жду от вас ACL-я.
------- Comment #7 From 2009-01-11 23:56:37 -------
nmu готов.
Правда тут глянул - можно было и без nmu - Вы в списке сборщиков, так что пакет
прошел бы и так :) Может, станете лидером для этого пакета?

Насчет gmo - не в курсе почему сейчас не подхватывалось, вроде бы раньше
работало и так, если мне мой склероз не изменяет :)
------- Comment #8 From 2009-01-12 01:16:22 -------
(In reply to comment #7)
> nmu готов.
> Правда тут глянул - можно было и без nmu - Вы в списке сборщиков,

Это я сегодня добавил.  Не люблю я nmu ;)

> так что пакет
> прошел бы и так :) Может, станете лидером для этого пакета?
> 
> Насчет gmo - не в курсе почему сейчас не подхватывалось, вроде бы раньше
> работало и так, если мне мой склероз не изменяет :)

*.gmo лучше удалать в любом случае.
А сломалось, вероятно, из-за съехавших timestamp'ов.
------- Comment #9 From 2009-01-12 06:49:19 -------
Fixed in 0.57.2-alt2.5
------- Comment #10 From 2009-01-12 06:54:34 -------
(In reply to comment #7)
> nmu готов.
> Правда тут глянул - можно было и без nmu - Вы в списке сборщиков, так что пакет
> прошел бы и так :) Может, станете лидером для этого пакета?

Лидером, это мэйнтейнером? Я не пользуюсь синаптиком и поставил его только для
того, чтобы этот баг исправить, а как исправил -- удалил. Я могу попробовать
собрать новую версию synaptic, если это надо, но мэйнтейнить его желания нет.