Bug 15520 - Needs symbols versioning
: Needs symbols versioning
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libglibmm)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
: 15079 15524
:
  Show dependency tree
 
Reported: 2008-05-01 02:36 by
Modified: 2011-01-22 16:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-01 02:36:02
gnome-system-monitor-2.22.0-alt1.qa1

$ ldd -r /usr/bin/gnome-system-monitor
        linux-gate.so.1 =>  (0xb7f2c000)
        libgtop-2.0.so.7 => /usr/lib/libgtop-2.0.so.7 (0xb7ef0000)
        libwnck-1.so.22 => /usr/lib/libwnck-1.so.22 (0xb7ebb000)
        libgnomevfs-2.so.0 => /usr/lib/libgnomevfs-2.so.0 (0xb7e63000)
        libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xb7e31000)
        libgtkmm-2.4.so.1 => /usr/lib/libgtkmm-2.4.so.1 (0xb7ba9000)
        libgdkmm-2.4.so.1 => /usr/lib/libgdkmm-2.4.so.1 (0xb7b6a000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb778d000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb76f8000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb75dc000)
        librsvg-2.so.2 => /usr/lib/librsvg-2.so.2 (0xb75ad000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb7593000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb752b000)
        libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0xb7528000)
        libglibmm-2.4.so.1 => /usr/lib/libglibmm-2.4.so.1 (0xb74e3000)
        libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0xb74aa000)
        libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xb74a3000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb73d8000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb72f2000)
        libm.so.6 => /lib/libm.so.6 (0xb72cc000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb72c1000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb72aa000)
        libc.so.6 => /lib/libc.so.6 (0xb7181000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb717e000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb7164000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb7128000)
        libstartup-notification-1.so.0 =>
/usr/lib/libstartup-notification-1.so.0 (0xb7120000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb7036000)
        libXRes.so.1 => /usr/lib/libXRes.so.1 (0xb7034000)
        libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0xb7030000)
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb7015000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb6fde000)
        libgnutls.so.13 => /usr/lib/libgnutls.so.13 (0xb6f6d000)
        libgcrypt.so.11 => /usr/lib/libgcrypt.so.11 (0xb6f1c000)
        libavahi-glib.so.1 => /usr/lib/libavahi-glib.so.1 (0xb6f19000)
        libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0xb6f0e000)
        libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0xb6eff000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb6eec000)
        libutil.so.1 => /lib/libutil.so.1 (0xb6ee8000)
        libORBit-2.so.0 => /usr/lib/libORBit-2.so.0 (0xb6e99000)
        libatkmm-1.6.so.1 => /usr/lib/libatkmm-1.6.so.1 (0xb6e5b000)
        libpangomm-1.4.so.1 => /usr/lib/libpangomm-1.4.so.1 (0xb6e37000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6e2e000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb6e28000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6dfd000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb6def000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6de7000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb6de4000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xb6ddb000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb6dd5000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb6dcc000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb6dc9000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb6dc6000)
        libdl.so.2 => /lib/libdl.so.2 (0xb6dc1000)
        libz.so.1 => /lib/libz.so.1 (0xb6dad000)
        libgsf-1.so.114 => /usr/lib/libgsf-1.so.114 (0xb6d7b000)
        libcroco-0.6.so.3 => /usr/lib/libcroco-0.6.so.3 (0xb6d45000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb6d1e000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6ca2000)
        libdirectfb-1.1.so.0 => /usr/lib/libdirectfb-1.1.so.0 (0xb6c33000)
        libdirect-1.1.so.0 => /usr/lib/libdirect-1.1.so.0 (0xb6c22000)
        libglitz.so.1 => /usr/lib/libglitz.so.1 (0xb6bfc000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb6bd9000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6baa000)
        /lib/ld-linux.so.2 (0x80000000)
        libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb6ba7000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6b8f000)
        librt.so.1 => /lib/librt.so.1 (0xb6b86000)
        libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0xb6b76000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0xb6b72000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb6b51000)
        libbz2.so.1 => /lib/libbz2.so.1 (0xb6b40000)
        libfusion-1.1.so.0 => /usr/lib/libfusion-1.1.so.0 (0xb6b38000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6b33000)
undefined symbol: pixman_format_supported_destination   (/usr/lib/libcairo.so.2)
undefined symbol: _ZNK4Glib5Regex9referenceEv   (/usr/bin/gnome-system-monitor)
undefined symbol: _ZNK4Glib5Regex11unreferenceEv       
(/usr/bin/gnome-system-monitor)
undefined symbol:
_ZN4Glib5Regex6createERKNS_7ustringENS_17RegexCompileFlagsENS_15RegexMatchFlagsE
     (/usr/bin/gnome-system-monitor)
undefined symbol: _ZN4Glib5Regex4gobjEv (/usr/bin/gnome-system-monitor)
undefined symbol: _ZN4Glib5Regex5matchERKNS_7ustringENS_15RegexMatchFlagsE     
(/usr/bin/gnome-system-monitor)
$ 

Steps to Reproduce:
$ gnome-system-monitor 
gnome-system-monitor: symbol lookup error: gnome-system-monitor: undefined
symbol:
_ZN4Glib5Regex6createERKNS_7ustringENS_17RegexCompileFlagsENS_15RegexMatchFlagsE
$
------- Comment #1 From 2008-05-01 13:35:34 -------
Ну обновите glibmm.
------- Comment #2 From 2008-05-01 14:57:25 -------
Да, спасибо, конечно.

Хорошо бы прописать обнаруженную зависимость от версии libglibmm.

(У меня пока был libglibmm-2.11.2-alt0.1.)
------- Comment #3 From 2008-05-01 16:00:54 -------
Версионировать надо, а не зависимости через багзиллу проставлять :-/
------- Comment #4 From 2008-05-02 00:36:46 -------
А кто-нибудь может подсказать как версионировать?
Что-то типа HOWTO на freesource.info :)
------- Comment #5 From 2008-05-02 02:32:38 -------
Аналогичная проблема https://bugzilla.altlinux.org/show_bug.cgi?id=15515 была
решена так:
http://git.altlinux.org/people/shrek/packages/?p=pixman.git;a=commitdiff;h=ebdf15b2ca8929208e32cb96b4ade223a99400d6
.
------- Comment #6 From 2009-07-25 12:55:56 -------
Переношу баг на glibmm.
------- Comment #7 From 2011-01-22 16:47:06 -------
*** Bug 15524 has been marked as a duplicate of this bug. ***
------- Comment #8 From 2011-01-22 16:47:44 -------
set provides:

$ rpm -q --provides libglibmm | tail -2
libglibmm_generate_extra_defs-2.4.so.1 = set:hdsKryfW2HBPK3gjEmU63
libglibmm = 2.25.5-alt1