Bug 15580 - Проблемы после пересборки роботом
: Проблемы после пересборки роботом
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/php5-pdo_mysql)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-05-08 14:43 by
Modified: 2008-05-16 23:14 (History)


Attachments
spec with a trivial workaround (2.40 KB, text/plain)
2008-05-10 18:41, Michael Shigorin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-08 14:43:59
После пересборки роботом неправильно установлены зависимости:

$ sudo apt-get install
/var/ftp/pub/ALTLinux/Sisyphus/files/i586/RPMS/php5-pdo_mysql-5.2.5-alt1.1.i586.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting php5-pdo_mysql for
'/var/ftp/pub/ALTLinux/Sisyphus/files/i586/RPMS/php5-pdo_mysql-5.2.5-alt1.1.i586.rpm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-pdo_mysql: Depends: php5-pdo (= 5.2.5-alt1)
E: Broken packages

Дело в особенностях php5-pdo_mysql.spec:
[...]
Requires: php5-pdo = %php5_version-%php5_release
[...]
------- Comment #1 From 2008-05-10 18:41:51 -------
Created an attachment (id=2611) [details]
spec with a trivial workaround

Ага.  Как раз поймал, устанавливая racktables.org.  Ослабил зависимости,
работает себе.
------- Comment #2 From 2008-05-16 21:02:53 -------
Ослабление зависимостей не желательно, т.к. исходный код модуля находится 
внутри дистрибутива PHP и может изменяться с изменением версии/релиза PHP.

Зависимость поправлена в php-pdo*-5.2.5-alt1.2
------- Comment #3 From 2008-05-16 23:14:09 -------
Я думаю, что, при таком раскладе, стоит собирать все пакеты php5-pdo* из одного
src.rpm...  Тогда можно чётко соблюсти эту зависимость вплоть до релиза...
Просто никакого смысла их разделять, в этом случае, нет... Исходники крохотные,
поэтому никаких проблем, с этим, быть не должно...