Bug 15603 - need to add "usepeerdns" by hand
: need to add "usepeerdns" by hand
Status: CLOSED FIXED
: Branch 4.0
(All bugs in Branch 4.0/alterator-net-pppoe)
: 4.0
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-05-12 02:56 by
Modified: 2014-01-10 19:26 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-12 02:56:21
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/4.0/Desktop/4.0.3/iso/altlinux-4.0.3-desktop-i586-install_ru-dvd5.iso

I needed to add "usepeerdns" by hand to /etc/net/.../pppoptions in order for
name resolution to work.

This seems similar to https://bugzilla.altlinux.org/show_bug.cgi?id=11958#c7 and
https://bugzilla.altlinux.org/show_bug.cgi?id=14116 (but those bug reports have
too many comments, so I create this report with describing the specific situation.)
Steps to Reproduce:
1. I configured Ethernet, pressed "Применить"
2. I configured PPPoE, pressed "Применить"
3.
Actual Results:  
The network works (pinging by IP addresses), but the name resolution doesn't
work (e.g., "ping ya.ru", or "resolve ya.ru").

(So, I add "usepeerdns" to /etc/net/.../pppoptions, then "ifdown ppp0", "ifup
ppp0", and name resolution works OK!)


Expected Results:  
There is a "usepeerdns" option in the GUI as well.
------- Comment #1 From 2008-05-12 03:57:08 -------
Funny: even if this is fixed in updates, generally speaking, one wouldn't be
able to install the updates  before he has configured the network. ;)

So, in a perfect world, fixes of alterator-net (as well as of the installer)
should trigger a new release of the distro ISO image.
------- Comment #2 From 2008-05-12 11:19:28 -------
Uh-oh.  Tawkin' 'bout release triggers, it's a tough matter: wish your problem
were the worst to be solved :-(
------- Comment #3 From 2008-05-12 11:22:04 -------
Fixed in branch indeed.

I can probably arrange for an installer or unofficial DVD build... but doubt
that would be of much use being unofficial.
------- Comment #4 From 2008-05-12 11:35:47 -------
Ouch!  *Not* fixed of course, misread your message but grepper the source and
didn't find "usepeerdns".
------- Comment #5 From 2008-05-12 11:56:35 -------
0.4.4-alt1:
+       shell_add_or_subst "usepeerdns" "" "$name/pppoptions"

Просьба проверить:
http://fly.osdn.org.ua/~mike/packages/alterator-net-pppoe/
------- Comment #6 From 2008-05-12 18:20:07 -------
(In reply to comment #3)
> Fixed in branch indeed.
> 
> I can probably arrange for an installer or unofficial DVD build... but doubt
> that would be of much use being unofficial.

Thanks, but no, I personally don't need such a thing, that was just a thought
about this situation. 
------- Comment #7 From 2008-05-12 18:26:24 -------
(In reply to comment #5)
> 0.4.4-alt1:
> +       shell_add_or_subst "usepeerdns" "" "$name/pppoptions"
> 
> Просьба проверить:
> http://fly.osdn.org.ua/~mike/packages/alterator-net-pppoe/

Спасибо! Я вообще не знаю, будет ли у меня когда-нибудь возможность проверить
это исправление на том компьютере с той сетью. Под рукой у меня PPPoE нет, так
что пусть кто-нибудь ещё проверит.
------- Comment #8 From 2014-01-10 19:26:46 -------
(В ответ на комментарий №1)
> Funny: even if this is fixed in updates, generally speaking, one wouldn't be
> able to install the updates  before he has configured the network. ;)
> 
> So, in a perfect world, fixes of alterator-net (as well as of the installer)
> should trigger a new release of the distro ISO image.

Well, now there are http://www.altlinux.org/Regular and 
http://www.altlinux.org/P7#starterkits which are re-done regularly. So they can
be regarded as a kind of fix for the problem of broken releases (which can't be
used after the installation because the network can't be configured)...