Bug 15604 - static-BIOS-codes was needed
: static-BIOS-codes was needed
Status: CLOSED WONTFIX
: Branch 4.0
(All bugs in Branch 4.0/lilo)
: 4.0
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 15605
  Show dependency tree
 
Reported: 2008-05-12 03:18 by
Modified: 2014-11-05 20:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-12 03:18:37
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/4.0/Desktop/4.0.3/iso/altlinux-4.0.3-desktop-i586-install_ru-dvd5.iso

Although "man lilo.conf" says about static-BIOS-codes: 

 In general, this option should never be used, except as a bug workaround.

I encountered a configuration where the only way to install a working LILO was
by using this option. So, it was probably a bug in lilo, wasn't it?

The computer had: /dev/hda (empty), /dev/hdb (the installer in the automatic
mode installed the ALTLinux system onto it), /dev/hdc (a CD drive), /dev/hdd (a
CD drive).

(Similar things were discussed in
https://bugzilla.altlinux.org/show_bug.cgi?id=6801 ,
https://bugzilla.altlinux.org/show_bug.cgi?id=6747 .)

Trying to install LILO onto /dev/hda results in a fatal error message, which had
the meaning like this: can't install LILO on /dev/hda because both /dev/hda and
/dev/hdb have the same BIOS code (0x80).

Installing LILO onto /dev/hdb succeeds, but is useless: the BIOS of this
computer has no possibility to boot from /dev/hdb, only from /dev/hda and /dev/hdc.

After I added "static-BIOS-codes" to /etc/lilo.conf, LILO could be installed
onto /dev/hda and it worked  (it successfully booted ALTLinux from /dev/hdb).




Expected Results:  
This situation can be handled by lilo without the special option which is
intended to be "a bug workaround" only.
------- Comment #1 From 2008-05-12 04:04:13 -------
https://bugzilla.altlinux.org/show_bug.cgi?id=15605 describes such a case.
------- Comment #2 From 2008-05-14 11:57:08 -------
(In reply to comment #0)
> In general, this option should never be used, except as a bug workaround.
> I encountered a configuration where the only way to install a working LILO was
> by using this option. So, it was probably a bug in lilo, wasn't it?
Probably in BIOS.
------- Comment #3 From 2008-05-18 00:29:45 -------
(In reply to comment #2)
> (In reply to comment #0)
> > In general, this option should never be used, except as a bug workaround.
> > I encountered a configuration where the only way to install a working LILO was
> > by using this option. So, it was probably a bug in lilo, wasn't it?
> Probably in BIOS.

Ah, I see. :) So, I misunderstood the manpage.

What to do with the bug? INVALID?
------- Comment #4 From 2008-05-18 01:21:17 -------
(In reply to comment #2)
> > In general, this option should never be used, except as a bug workaround.

> Probably in BIOS.

But, well, I haven't dealt much with IDE, so I don't know whether it's normal:
this BIOS could only boot from /dev/hda and /dev/hdc. I considered it to be an
acceptable restriction of the BIOS and not a bug. But then, if I want to boot
the ALTLinux system installed on /dev/hdb, I need to install lilo to /dev/hda.
But lilo doesn't want to install itself onto /dev/hda without this option (I
think, it's important that the kernel is on /dev/hdb in this case). Isn't it a
problem of lilo?
------- Comment #5 From 2014-11-05 20:16:20 -------
В 4.0/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.