Bug 15625 - a non-declared conflict?
: a non-declared conflict?
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sysvinit-utils)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-05-12 17:56 by
Modified: 2010-08-05 21:59 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-12 17:56:07
sysvinit-utils-2.86-alt2 conflicts with SysVinit-2.86-alt1 in files, but this
conflict is not declared in the package.
Steps to Reproduce:
# ftp_proxy= http_proxy= apt-shell 
Reading Package Lists... Done
Building Dependency Tree... Done
Welcome to the APT shell. Type "help" for more information.
apt> install startup
Unrequested changes are needed to execute this operation.
The following packages will be upgraded
  startup
The following NEW packages will be installed:
  sysvinit-utils
1 upgraded, 1 newly installed, 0 removed and 0 kept.
Will need more 72.6kB of archives.
After unpacking will need more 57.5kB of disk space.
Do you want to continue? [Y/n] 
apt> commit 
The following packages will be upgraded
  startup
The following NEW packages will be installed:
  sysvinit-utils
1 upgraded, 1 newly installed, 0 removed and 1508 not upgraded.
Need to get 72.6kB of archives.
After unpacking 57.5kB of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 ftp://ftp.altlinux.org i586/classic sysvinit-utils 2.86-alt2 [38.6kB]
Get:2 ftp://ftp.altlinux.org noarch/classic startup 0.9.8.19-alt1 [34.0kB]
Fetched 72.6kB in 0s (624kB/s)
Committing changes...
Preparing...                                                   
###################################################################################################
[100%]
file /bin/mountpoint from install of sysvinit-utils-2.86-alt2 conflicts with
file from package SysVinit-2.86-alt1
file /sbin/bootlogd from install of sysvinit-utils-2.86-alt2 conflicts with file
from package SysVinit-2.86-alt1
file /sbin/killall5 from install of sysvinit-utils-2.86-alt2 conflicts with file
from package SysVinit-2.86-alt1
file /usr/bin/last from install of sysvinit-utils-2.86-alt2 conflicts with file
from package SysVinit-2.86-alt1
file /usr/bin/mesg from install of sysvinit-utils-2.86-alt2 conflicts with file
from package SysVinit-2.86-alt1
file /usr/bin/wall from install of sysvinit-utils-2.86-alt2 conflicts with file
from package SysVinit-2.86-alt1
E: Error while running transaction
Reading Package Lists... Done
Building Dependency Tree... Done
E: Handler silently failed
apt>
------- Comment #1 From 2008-05-27 02:24:22 -------
(In reply to comment #0)
> sysvinit-utils-2.86-alt2 conflicts with SysVinit-2.86-alt1 in files, but this
> conflict is not declared in the package.

Это было сделано с целью упростить появление в репозитории пакета,
альтернативного SysVinit.
------- Comment #2 From 2009-01-19 00:53:04 -------
*** Bug 18552 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2009-01-19 02:44:07 -------
ну конфликт-то на версию меньше alt2 можно сделать?
или оно тогда не будет пытаться обновлять?
------- Comment #4 From 2009-01-19 02:54:20 -------
(In reply to comment #3)
> ну конфликт-то на версию меньше alt2 можно сделать?
> или оно тогда не будет пытаться обновлять?

$ rpmquery -p --provides upstart-0.3.9-alt3.i586.rpm 
SysVinit  

Если в пакете будет
Conflicts: SysVinit < 2.86-alt2
то как тогда установить пакет upstart?
------- Comment #5 From 2009-09-14 14:36:46 -------
(In reply to comment #4)
> Если в пакете будет
> Conflicts: SysVinit < 2.86-alt2
> то как тогда установить пакет upstart?
Может, это оставить следующему желающему заняться upstart?
------- Comment #6 From 2010-08-05 21:59:15 -------
SysVinit-2.88-alt1 -> sisyphus:

* Thu Aug 05 2010 Dmitry V. Levin <ldv@altlinux> 2.88-alt1
- Updated to 2.88-11.
- Enabled SELinux support.
- sysvinit-utils: added controversial Conflict (closes: #15625).
- Fixed wall(1) output.