Bug 15925 - Странная установка "виртуальных пакетов" которые указаны как файлы в командной строке
: Странная установка "виртуальных пакетов" которые указаны как файлы в командно...
Status: NEW
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P5 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-05 15:46 by
Modified: 2011-05-02 10:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-06-05 15:46:46
Качаем два пакета в текущий каталог:
http://ftp.altlinux.org/pub/people/raorn/aptitude/Sisyphus/i586/RPMS.hasher/aptitude-0.4.5-alt1.1.i586.rpm
http://ftp.altlinux.org/pub/distributions/archive/Sisyphus/2007/04/01/files/i586/RPMS/less-394-alt1.i586.rpm

1) # apt-get install aptitude-0.4.5-alt1.1.i586.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
E: Package aptitude-0.4.5-alt1.1.i586.rpm is a virtual package with no good
providers.

1.1) # apt-get install aptitude-0.4.5-alt1.1.i586.rpm aptitude=0.4.5-alt1.1
Reading Package Lists... Done
Building Dependency Tree... Done
E: Package aptitude-0.4.5-alt1.1.i586.rpm is a virtual package with no good
providers.

2) # apt-get install less-394-alt1.i586.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting less for 'less-394-alt1.i586.rpm'
less is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 85 not upgraded.

2.1) # apt-get install less-394-alt1.i586.rpm less=394-alt1
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting less for 'less-394-alt1.i586.rpm'
less is already the newest version.
The following packages will be DOWNGRADED
  less
0 upgraded, 0 newly installed, 1 downgraded, 0 removed and 85 not upgraded.

3) # apt-get install less=394-alt1
Reading Package Lists... Done
Building Dependency Tree... Done
E: Version ='394-alt1' for 'less' was not found

В случаях 1) и 1.1) пакет не находится вообще (хотя должен).  В случае 2) пакет
находится, но отказывается обновляться.  В случае 2.1) всё работает как и
задумывалось, но немного смущает "already the newest version".  Случай 3) для
очистки совести, чтобы показать что less=394-alt1 в подключенных репозитариях
отсутствует.
------- Comment #1 From 2008-06-06 04:04:47 -------
Не осталось слов кроме непечатны.  Случаи за номерами 1 и 1.1 как оказалось
ломал /etc/apt/preferences следующего вида:

Package: *
Pin: release c=hasher
Pin-Priority: 999

Package: *
Pin: release c=classic
Pin-Priority: 990

Package: *
Pin: release c=daedalus
Pin-Priority: 110

При том что подключены только classic из Sisyphus и локального репозитария.
------- Comment #2 From 2008-06-06 04:15:46 -------
А ещё мы не ловим Serial/Epoch (см. bug 15909):

Ох какой классный эффект словил!

# cp /Sisyphus/files/i586/RPMS/rpm-4.0.4-alt92.i586.rpm rpm
# apt-get install rpm
Reading Package Lists... Done
Building Dependency Tree... Done
rpm is already the newest version.
You might want to run `apt-get --fix-broken install' to correct these:
The following packages have unmet dependencies:
  rootfiles: Conflicts: rpm (< 0:4.0.4-alt1)
  service: Conflicts: rpm (< 0:4.0.4-alt0.7)
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or
specify a solution).