Bug 16017 - wrong charset in help/usage diagnostics
: wrong charset in help/usage diagnostics
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libpopt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-14 01:45 by
Modified: 2008-09-02 03:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-06-14 01:45:30
rpm or popt error, e.g.

$ locale
LANG=ru_RU.KOI8-R
LC_CTYPE="ru_RU.KOI8-R"
LC_NUMERIC="ru_RU.KOI8-R"
LC_TIME="ru_RU.KOI8-R"
LC_COLLATE="ru_RU.KOI8-R"
LC_MONETARY="ru_RU.KOI8-R"
LC_MESSAGES="ru_RU.KOI8-R"
LC_PAPER="ru_RU.KOI8-R"
LC_NAME="ru_RU.KOI8-R"
LC_ADDRESS="ru_RU.KOI8-R"
LC_TELEPHONE="ru_RU.KOI8-R"
LC_MEASUREMENT="ru_RU.KOI8-R"
LC_IDENTIFICATION="ru_RU.KOI8-R"
LC_ALL=
$ rpmquery -z
-z: п╫п╣п╦п╥п╡п╣я│я┌п╫я▀п╧ п©п╟я─п╟п╪п╣я┌я─
$ rpmquery -z 2>&1 |iconv -futf8
-z: неизвестный параметр
------- Comment #1 From 2008-06-15 01:27:51 -------
libpopt-1.14 regression
------- Comment #2 From 2008-07-16 19:18:25 -------
*** Bug 16371 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2008-09-02 03:24:06 -------
Fixed in 1.14-alt3