Bug 16121 - Падает "ООо"
: Падает "ООо"
Status: CLOSED WONTFIX
: Branch 4.0
(All bugs in Branch 4.0/openoffice.org-kde)
: 4.0
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-20 19:58 by
Modified: 2009-03-03 13:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-06-20 19:58:39
После очередного обновления сразу после запуска падает OpenOffis. При следующем
запуске предлагается восстановить предыдущий документ но после того как
восстановление закончено OOO вновь падает. Если не восстанавливать то
происходит то же самое. Падает как при открытии различных файлов, которые ранее
открывались нормально так и при простом запуске ООо.
------- Comment #1 From 2008-06-20 20:04:14 -------
как воспроизвести?
------- Comment #2 From 2008-06-20 20:08:50 -------
У меня: система  ald 4.0 + branch 4.0 
обновил ООо до версии 4.2.1 после этого после каждого открытия любого документа
ООо просто открывшись тут же закрывается а как воспроизвести не знаю :(
------- Comment #3 From 2008-06-20 20:14:51 -------
архитектура какая?
у кого то еще воспроизводится?
------- Comment #4 From 2008-06-20 20:26:39 -------
lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 650/M650 Host (rev 80)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge
(AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO]
(rev 25)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS]
65x/M650/740 PCI/AGP VGA Display Adapter

Вроде больше никого рядом нету, чтобы посмотреть воспроизводиться или нет, в
рассылке один писал что у него работает нормально остальные сказали что на
бренче 4.1 уже давно bf трам аботает
------- Comment #5 From 2008-06-20 20:33:37 -------
под архитектурой имелось ввиду i586 или x86_64.
но по любому единичный случай не показатель
вот если его запустить под gdb, тогда хоть будет понятно на чем он валится
------- Comment #6 From 2008-06-20 20:36:11 -------
i586
------- Comment #7 From 2008-06-20 20:52:26 -------
а strace oowriter >log  не поможет?
------- Comment #8 From 2008-06-20 21:07:02 -------
strace это несколько не то
------- Comment #9 From 2008-06-20 21:10:37 -------
тогда объясните пожалуйста как запустить ООо под gdb? я начал читать
http://mitya.pp.ru/gdb/gdb_2.html но это на долго. попробовал как всегда наобум
не получилось :(
GNU gdb 6.6-alt2 (ALT Linux)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-alt-linux".
(gdb) oowriter
Undefined command: "oowriter".  Try "help".
------- Comment #10 From 2008-06-20 21:41:38 -------
$ gdb /usr/lib/openoffice.org/program/soffice.bin
GNU gdb 6.6-alt3 (ALT Linux)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-alt-linux"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb)  run
------- Comment #11 From 2008-06-20 21:44:28 -------
run
Starting program: /usr/lib/openoffice.org/program/soffice.bin
(no debugging symbols found)
Failed to read a valid object file image from memory.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1252358448 (LWP 5995)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
------- Comment #12 From 2008-06-20 21:50:08 -------
run
Starting program: /usr/lib/openoffice.org/program/soffice.bin
(no debugging symbols found)
Failed to read a valid object file image from memory.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1252358448 (LWP 5995)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
warning: Lowest section in /usr/lib/libicudata.so.36 is .gnu.hash at 000000b4
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1279698032 (LWP 6035)]
[New Thread -1288086640 (LWP 6036)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
[New Thread -1297568880 (LWP 6037)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1325933680 (LWP 6038)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1339061360 (LWP 6041)]
(no debugging symbols found)
[Thread -1339061360 (LWP 6041) exited]
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1339061360 (LWP 6042)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread -1361417328 (LWP 6045)]
[Thread -1361417328 (LWP 6045) exited]
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1252358448 (LWP 5995)]
0x00000000 in ?? ()
(gdb)
------- Comment #13 From 2008-06-20 22:01:27 -------
н-да. без отладки тоже не информативно. а сколько памяти на компе? и покажите
вывод от df
------- Comment #14 From 2008-06-20 22:07:34 -------
df
Файловая система      Разм  Исп  Дост  Исп% смонтирована на
/dev/hda1             4,6G  3,7G  768M  83% /
udevfs                5,0M   72K  5,0M   2% /dev
shmfs                 173M     0  173M   0% /dev/shm
tmpfs                 173M   28K  173M   1% /tmp
/dev/hda6              27G   16G   11G  60% /home
/dev/hda5             4,6G  1,4G  3,0G  32% /var

оперативной памяти вроде 512 было, но видео и аудио встроенные
------- Comment #15 From 2008-06-20 22:10:45 -------
единственное что смущает
Failed to read a valid object file image from memory.
------- Comment #16 From 2008-06-21 09:21:49 -------
но до обновления то всё работало нормально. а падать стало после обновления.
поставил koffic он работает нормально, всё открывает и не падает.
------- Comment #17 From 2008-06-21 13:34:00 -------
Обнаружил ещё одну вещь. Если зайти под другим именем то всё работает нормально
и ничего не падает. Та же самая машина, та же самая память. Пробовал у себя
удалить каталог .openoffice.org2.0 не помогает.
------- Comment #18 From 2008-06-21 14:14:23 -------
увы и ах
------- Comment #19 From 2008-06-30 19:49:36 -------
Раскопки показали, что падения возникают тогда, когда в
/home/.kde/share/config/kdeglobals присутствует запись
[General]
widgetStyle=Keramik

Вместо керамики пробовал пластик, падает так же. Если закомментировать
#widgetStyle=Keramik то всё нормально грузиться. При перезагрузке компьютера
всё продолжает работать, стоит только в центре управления КДЕ поменять тему,
как вновь добавляется запись widgetStyle=Keramik и вновь падает ООо

В рассылке данную проблему обсуждал, ещё у двоих воспроизвелась та же самая
ошибка.
------- Comment #20 From 2009-01-27 15:01:09 -------
4.0 уже в прошлом