Bug 16276 - Не срабатывает поределение кодировки писем от багзиллы
: Не срабатывает поределение кодировки писем от багзиллы
Status: CLOSED WORKSFORME
: Infrastructure
(All bugs in Infrastructure/bugzilla.altlinux.org)
: unspecified
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-05 01:40 by
Modified: 2008-08-09 23:14 (History)


Attachments
содержимое письма (3.55 KB, text/plain)
2008-07-05 14:32, Alexei V. Mezin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-07-05 01:40:31
Письма от багзиллы (с новыми сообщениями и комментариями к багу) приходят в
UTF. Thunderbird под Линуксом не может корректно определить кодировку, и
показывает письмо кракозябрами (при этом под виндой все нормально). Нельзя ли
как-то допилить заголовок письма, чтоб все корректно отображалось?
------- Comment #1 From 2008-07-05 11:14:02 -------
Приложите глючащее письмо с заголовками. У меня всё замечательно работает:

Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
------- Comment #2 From 2008-07-05 14:32:32 -------
Created an attachment (id=2695) [details]
содержимое письма
------- Comment #3 From 2008-07-05 14:35:30 -------
При добавлении новых данных в баг, закрытый как WORKSFORME, стоит переоткрыть
баг, а то есть риск, что он так и будет висеть закрытым до скончания времён.
------- Comment #4 From 2008-07-05 15:08:25 -------
Какие версии Thunderbird в линуксе и в винде?
------- Comment #5 From 2008-07-05 15:12:48 -------
(In reply to comment #4)
> Какие версии Thunderbird в линуксе и в винде?
> 

И там и там 2.0.0.14, сборки с официального сайта, из плагинов стоит только
Lightning и словарь русский. Локаль ср1251, для писем в настройках указана
"кодиовка по умолчанию кои8".
------- Comment #6 From 2008-07-05 15:24:10 -------
У меня, честно говоря, нет никаких идей: в заголовках всё корректно по RFC
2045.

Советую в bugzilla.mozilla.org с этим обратиться. А этот баг пока пусть
повисит, вдруг что в голову придёт.
------- Comment #7 From 2008-08-08 12:11:28 -------
Решил ещё поковыряться: не вопроизводится.

Проверьте, что у вас в настройках кодировок снят флажок "использовать charset
по умолчанию для всех входящих писем".
------- Comment #8 From 2008-08-08 12:11:51 -------
worksforme до получения дополнительной информации.
------- Comment #9 From 2008-08-09 21:22:36 -------
(In reply to comment #8)
> worksforme до получения дополнительной информации.
> 

Работает. Можно закрывать.
------- Comment #10 From 2008-08-09 21:26:50 -------
А в чём было дело - во флажке или просто само наладилось? :)
------- Comment #11 From 2008-08-09 23:14:57 -------
(In reply to comment #10)
> А в чём было дело - во флажке или просто само наладилось? :)
> 

Во флажке.