Bug 1664 - Bad encoding when search from location bar
: Bad encoding when search from location bar
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mozilla)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-12-04 17:10 by
Modified: 2005-10-16 13:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-12-04 17:10:45
В 1.2.х перестала корректно работать удобная фича - отправлять запрос на
поисковик, набрав его в строке урла. Запрос-то отправляется, но русские буквы
неправильно транслируются.
В 1.0 это работало нормально.

Например, набрав \"что-нить про мозиллу\" и
выбрав \"Поиск (Google)\", получаем урл:

<a
href="http://www.google.com/search?q=%DE%D4%CF-%CE%C9%D4%D8+%D0%D2%CF+%CD%CF%DA%C9%CC%CC%D5&amp;sourceid=mozilla-search&amp;start=0&amp;start=0">http://www.google.com/search?q=%DE%D4%CF-%CE%C9%D4%D8+%D0%D2%CF+%CD%CF%DA%C9%CC%CC%D5&amp;sourceid=mozilla-search&amp;start=0&amp;start=0</a>

а в результирующей странице пустой результат и такое вот
в строке запроса: ЮФП-ОЙФШ РТП НПЪЙММХ

---

---
mozilla-1.2.1-alt1
системная кодировка: KOI8-R
------- Comment #1 From 2002-12-04 17:59:44 -------
Исправлено в ALT2
------- Comment #2 From 2002-12-04 17:59:44 -------
Исправлено в ALT2
------- Comment #3 From 2003-04-16 12:37:06 -------
В 1.3 это снова сломано :(
$ rpm -q mozilla
mozilla-1.3-alt2
------- Comment #4 From 2003-04-16 12:37:06 -------
В 1.3 это снова сломано :(
$ rpm -q mozilla
mozilla-1.3-alt2
------- Comment #5 From 2004-05-05 16:26:57 -------
подарок новому мантейнеру 
------- Comment #6 From 2005-09-02 16:59:30 -------
Ух какая махровая бага... :)
Сейчас уже все работает:)