Bug 16679 - configure скрипт пакетов перестал корректно проверять библиотеки
: configure скрипт пакетов перестал корректно проверять библиотеки
Status: CLOSED NOTABUG
: Branch 4.1
(All bugs in Branch 4.1/autoconf-common)
: unspecified
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-08-13 13:39 by
Modified: 2008-08-17 17:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-08-13 13:39:57
С некоторых пор заметил неработоспособность проверки h-файлов и библиотек,
которые нужны программе скриптом configure, сгенерированного autoconf. С
версией autoconf это похоже не кореллирует поскольку пробовал на 2.6.1 и 2.5.9.

При проверке сообщается:
Build module: DB/MySQL
checking mysql/mysql.h usability... no
checking mysql/mysql.h presence... yes
configure: WARNING: mysql/mysql.h: present but cannot be compiled
configure: WARNING: mysql/mysql.h:     check for missing prerequisite headers?
configure: WARNING: mysql/mysql.h: see the Autoconf documentation
configure: WARNING: mysql/mysql.h:     section "Present But Cannot Be Compiled"
configure: WARNING: mysql/mysql.h: proceeding with the preprocessor's result
configure: WARNING: mysql/mysql.h: in the future, the compiler will take
precedence
configure: WARNING:     ## -------------------------------- ##
configure: WARNING:     ## Report this to rom_as@fromru.com ##
configure: WARNING:     ## -------------------------------- ##
checking for mysql_init in -lmysqlclient... no
configure: error: DB/MySQL: MySQL API library not found. Install or check MySQL
library package!

Библиотека точно есть, кроме того если отключить поддержку MySQL спотыкается с
подобным сообщением на SQLite.

В то-же время на SuSE 11, с этим-же скриптом всё работает.
------- Comment #1 From 2008-08-13 13:50:21 -------
Со скриптом configure сгенерированным ориентировачно месяц назад этой проблемы
нет.

Ещё, при установка configure вываливается сообщение об отсутствии какого-то
файла от phyton 2.4 в alternatives, хотя уже давно 2.5
------- Comment #2 From 2008-08-13 13:52:13 -------
При установке autoconf.
------- Comment #3 From 2008-08-13 13:58:44 -------
Прошу прощения.
Это какие-то остатки при операциях в разных дистрибутивах мешали.
------- Comment #4 From 2008-08-17 17:05:55 -------
Как обычно, короче.