Bug 16900 - apt: слишком много пакетов
: apt: слишком много пакетов
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
: http://www.altlinux.org/Changes/apt
:
:
:
  Show dependency tree
 
Reported: 2008-08-26 16:47 by
Modified: 2012-03-16 13:59 (History)


Attachments
patch by led@ (1.01 KB, patch)
2008-08-27 18:07, Michael Shigorin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-08-26 16:47:40
В последнее время mkaptbox на Sisyphus/i586+noarch вываливается с такой
ошибкой:

E: Wow, you exceeded the number of package names this APT is capable of.
E: Problem with MergeList
/tmp/aptbox/var/lib/apt/lists/_ALT_Sisyphus_noarch_base_pkglist.classic
E: The package lists or status file could not be parsed or opened.

Нельзя ли увеличить соответствующий лимит?
------- Comment #1 From 2008-08-27 04:58:36 -------
(In reply to comment #0)
> Нельзя ли увеличить соответствующий лимит?

Можно и ИМХО нужно. И даже второй день уже нормально работает.
------- Comment #2 From 2008-08-27 18:07:22 -------
Created an attachment (id=2854) [details]
patch by led@
------- Comment #3 From 2008-08-27 20:16:20 -------
Раз это работает, то я, пожалуй, залью завтра новую версию apt, приложив второй
hunk из этого патча. (Я там, оказывается, есть в ACL.)
------- Comment #4 From 2008-08-27 20:36:42 -------
Как насчёт 16311, 15909 и 14929 ?
------- Comment #5 From 2008-08-27 21:00:24 -------
(In reply to comment #3)
> Раз это работает, то я, пожалуй, залью завтра новую версию apt, приложив второй
> hunk из этого патча. (Я там, оказывается, есть в ACL.)

Почему только второй? Чтоб просто сломать apt?
------- Comment #6 From 2008-08-27 21:09:30 -------
Объясните, пожалуйста, этот первый ханк. Мне кажется, что (1ULL << 4*8) - 1
ничем не отличается от UINT_MAX.
------- Comment #7 From 2008-08-27 21:23:21 -------
(In reply to comment #6)
> Объясните, пожалуйста, этот первый ханк. Мне кажется, что (1ULL << 4*8) - 1 ничем не
> отличается от UINT_MAX.

Принципиально - не очень. Просто лишний оверхэд. так что на счёт "поломает" я
погорячился:)
------- Comment #8 From 2008-09-05 23:49:14 -------
(In reply to comment #7)
> Принципиально - не очень. Просто лишний оверхэд. так что на счёт "поломает" я
> погорячился:)
И насчёт "оверхэда" тоже погорячились.

А бага-то FIXED.
------- Comment #9 From 2008-09-06 01:05:05 -------
(In reply to comment #8)
> И насчёт "оверхэда" тоже погорячились.

Не думаю.
------- Comment #10 From 2008-12-23 12:13:23 -------
Можно apt с таким же изменением залить в branch/{4.1,4.0} ?

Обновление до Sisyphus сейчас сломано.
------- Comment #11 From 2009-04-19 22:58:12 -------
чтоб лучше искалось:

E: Dynamic MMap ran out of room
------- Comment #12 From 2009-12-14 07:03:53 -------
A similar situation appeared again:
https://bugzilla.altlinux.org/show_bug.cgi?id=22528 .
------- Comment #13 From 2009-12-14 20:43:18 -------
documented: http://www.altlinux.org/Changes/apt