Bug 16977 - Не работает сеть в altlinux-4.1.0-beta-20080827-desktop-i586-ru-dvd.iso
: Не работает сеть в altlinux-4.1.0-beta-20080827-desktop-i586-ru-dvd.iso
Status: CLOSED FIXED
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: snapshot
: x86 Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-01 20:34 by
Modified: 2008-09-25 14:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-01 20:34:32
После установки системы с  altlinux-4.1.0-beta-20080827-desktop-i586-ru-dvd.iso
и первой загрузки системы сеть не работает. Порядок тестирования:

Шёл полностью след-в-след за инсталятором.
Разбивка диска вручную.
Когда дошло до конфигурирования сети, то я сказал, что настрою вручную.
Дальше - два варианта
1. С двумя сетевыми картами. Инсталятор говорит, что оба интерфейса
выключены, но кабель подключен к обоим (на самом деле только к одной
карте!). Дальше без разницы, задаю ли я адреса обоим, выключаю одну, а
адрес даю второй, без привязки или с привязкой к месту или МАС адресу,
результат один - сразу после первой перезагрузки сети нет.
2. С одной сетевой картой гадать не приходится, кто есть кто, задаю
адрес, нейм-сервера, шлюз, делал без привязки, с привязкой по месту, с
привязкой по МАС результат тот же.
Пингую собственный адрес:
 pavel@alt_pavel ~ $ ping 192.168.50.33
connect: Network is unreachable

pavel@alt_pavel /var/log $ sudo ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
qlen 1000 link/ether 00:0a:cd:02:57:b9 brd ff:ff:ff:ff:ff:ff

    В логах бодренькое:
.....
Sep  1 07:57:42 alt_pavel network: Computing interface groups: 
Sep  1 07:57:42 alt_pavel network: . 
Sep  1 07:57:42 alt_pavel network: . 
Sep  1 07:57:42 alt_pavel network:  2 interfaces found 
Sep  1 07:57:42 alt_pavel network: Starting group 0/virtual (1
interfaces) Sep  1 07:57:42 alt_pavel network: ^IStarting lo: 
Sep  1 07:57:42 alt_pavel network: . 
Sep  1 07:57:42 alt_pavel last message repeated 3 times
Sep  1 07:57:42 alt_pavel network: OK 
Sep  1 07:57:42 alt_pavel network: Starting group 1/realphys (1
interfaces) Sep  1 07:57:42 alt_pavel network: ^IStarting eth0: 
Sep  1 07:57:42 alt_pavel network: . 
Sep  1 07:57:42 alt_pavel last message repeated 5 times
Sep  1 07:57:42 alt_pavel network: OK 
Sep  1 07:57:42 alt_pavel network: Processing /etc/net/vlantab: 
Sep  1 07:57:42 alt_pavel network: empty. 
Sep  1 07:57:42 alt_pavel rc: Starting network: succeeded 
....
 После service network restart (start) у сетевушек появляются адреса...
------- Comment #1 From 2008-09-03 05:41:48 -------
После удаления пакета NetworkManager сеть работает так, как должна - сразу
после загрузки.
------- Comment #2 From 2008-09-25 14:08:34 -------
В сборке Бояршинова ALTLinux 4.1 Desktop Personal beta от 23 сентября ошибка не
воспроизводится