Bug 17033 - Не монтируются внешние USB-носители с НТФС
: Не монтируются внешние USB-носители с НТФС
Status: CLOSED DUPLICATE of bug 17055
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.1.0
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-05 19:58 by
Modified: 2008-09-22 16:22 (History)


Attachments
Чтобы автоматом монтировало ntfs (1.92 KB, application/octet-stream)
2008-09-07 12:00, Arc
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-05 19:58:37
4,1 бета ДВД (и частично проверено на Lite).

Флэшка, отформатированная в НТФС (по сообщениям на форуме, внешние
USB-коробочки с хардами аналогично) монтируется с драйвером ntfs. Запись на нее
невозможна. При попытке прикрутить совет отсюда: http://www.altlinux.org/NTFS3G
получаю ошибку КДЕ, описанную тут:
http://bbs.archlinux.org/viewtopic.php?id=42070

Логи и подробная информация тут:
http://lists.altlinux.org/pipermail/desktop/2008-September/007942.html
------- Comment #1 From 2008-09-06 22:43:45 -------
(In reply to comment #0)
> При попытке прикрутить совет отсюда: http://www.altlinux.org/NTFS3G получаю
> ошибку КДЕ, описанную тут: http://bbs.archlinux.org/viewtopic.php?id=42070
Эта ошибка возникает из-за опции "uid=" и её можно устранить, например, вставив
в fdi строчку:
<remove key="volume.mount.valid_options" type="strlist">uid=</remove>

Просьбу же о включении монтирования внешних носителей через ntfs-3g
поддерживаю, ибо если на установленной системе можно это настроить один раз, то
live-версией с внешними ntfs-носителями работать очень грустно без
"искаробочной" поддержки.
------- Comment #2 From 2008-09-07 11:55:00 -------
>Эта ошибка возникает из-за опции "uid=" и её можно устранить, например, вставив
>в fdi строчку:
><remove key="volume.mount.valid_options" type="strlist">uid=</remove>
В какой файлик не подскажите?

У меня отлично работает вот это:
/usr/share/hal/fdi/policy/10osvendor/10-ntfs-policy.fdi

--------------------------------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
   <device>
       <match key="volume.fstype" string="ntfs">
           <match key="@block.storage_device:storage.hotpluggable" bool="true">
               <merge key="volume.fstype" type="string">ntfs-3g</merge>
               <merge key="volume.policy.mount_filesystem"
type="string">ntfs-3g</merge>
               <append key="volume.mount.valid_options"
type="strlist">locale=</append>
               <append key="volume.mount.valid_options"
type="strlist">umask=</append>
               #<append key="volume.mount.valid_options"
type="strlist">dmask=</append>
               #<append key="volume.mount.valid_options"
type="strlist">fmask=</append>
               <append key="volume.mount.valid_options"
type="strlist">silent</append>
               #<append key="volume.mount.valid_options"
type="strlist">allow_other</append>
               <append key="volume.mount.valid_options"
type="strlist">streams_interface=</append>
               <append key="volume.mount.valid_options"
type="strlist">locale=</append>
               <merge key="volume.policy.mount_option.locale=ru_RU.UTF-8"
type="bool">true</merge>
               <merge key="volume.policy.mount_option.umask=0"
type="bool">true</merge>
               #<merge key="volume.policy.mount_option.dmask=0"
type="bool">true</merge>
               #<merge key="volume.policy.mount_option.fmask=0"
type="bool">true</merge>
               #<merge key="volume.policy.mount_option.allow_other"
type="bool">true</merge>
               <merge key="volume.policy.mount_option.silent"
type="bool">true</merge>
               <merge
key="volume.policy.mount_option.streams_interface=windows"
type="bool">true</merge>
              #<append key="volume.mount.valid_options"
type="strlist">force</append>
              #<merge key="volume.policy.mount_option.force"
type="bool">true</merge>
           </match>
       </match>
   </device>
</deviceinfo>
---------------------------------------------------------------
------- Comment #3 From 2008-09-07 12:00:04 -------
Created an attachment (id=2884) [details]
Чтобы автоматом монтировало ntfs

Текст fdi в предыдущем коменте слегка побился, прицепил его в файле.
/usr/share/hal/fdi/policy/10osvendor/10-ntfs-policy.fdi
------- Comment #4 From 2008-09-07 13:12:54 -------
(In reply to comment #2)
> В какой файлик не подскажите?
Ну да, именно в 10-ntfs-policy.fdi
где-нибудь между <match> и </match>

> У меня отлично работает вот это:
Ваш вариант мало чем отличается от http://www.altlinux.org/NTFS3G
но по умолчанию там установлена галка "Подключить используя права
пользователя", если её снять, то монтируется нормально, иначе ошибка.
Вот строчка с <remove> вообще удаляет эту опцию из списка доступных.
------- Comment #5 From 2008-09-07 17:00:20 -------
>> В какой файлик не подскажите?
>Ну да, именно в 10-ntfs-policy.fdi
>где-нибудь между <match> и </match>
По умолчанию, по крайней мере в 4.0.3 и моем текущем 4.1 этого файла нет.
>> У меня отлично работает вот это:
>Ваш вариант мало чем отличается от http://www.altlinux.org/NTFS3G
Именно из-за этого "мало чем" -- этот вариант работает сразу и проблем  с
правами при копировании не возникает(проверно на 4х машинах). Просто скопируйте
и перезагрузите hal, в KDE ничего трогать не надо.
------- Comment #6 From 2008-09-07 18:10:15 -------
(In reply to comment #5)
>> Ну да, именно в 10-ntfs-policy.fdi
>> где-нибудь между <match> и </match>
> По умолчанию, по крайней мере в 4.0.3 и моем текущем 4.1 этого файла нет.
Разумеется у меня тоже не было. Но я первым сообщением отвечал на конкретную
часть конкретного сообщения, где описывался именно этот файл.

>> Ваш вариант мало чем отличается от http://www.altlinux.org/NTFS3G
> Именно из-за этого "мало чем" -- этот вариант работает сразу и проблем  с
> правами при копировании не возникает(проверно на 4х машинах).
Проблемы с правами при _копировании_ это отдельная тема, здесь же речь идёт о
проблемах при _монтировании_. Я даже больше скажу - за исключением масок на
доступ к файлам и катологам эти файлы вообще ничем не отличаются. А вот сможете
ли вы объяснить, зачем в вашем файле столько бесполезных символов '#'? Если вы
собирались закомментировать эти строчки, то вам это не удалось.

> Просто скопируйте и перезагрузите hal, в KDE ничего трогать не надо.
Это было сделано в первую очередь, как на основной машине с 4.1/branch, так и
на свежепоставленной beta-20080822. Результат ожидаемый, при монтировании:
"Ошибка - kio_media_mounthelper"
"TODO: have to rethink extra options"
Лечится снятием вышеописанной галки один раз, после чего работает нормально.
Если вдруг у вас почему-то этой проблемы не было, то это не значит, что её не
будет ни у кого.
------- Comment #7 From 2008-09-07 20:07:11 -------
>здесь же речь идёт о
>проблемах при _монтировании_
Я в курсе. Просто решив для себя проблему с монтированием. Получил новую с
правами на файлы, для меня, по крайней мере это вещи взаимосвязанные.
>Я даже больше скажу - за исключением масок на
>доступ к файлам и катологам эти файлы вообще ничем не отличаются.
А должны?
>Если вы собирались закомментировать эти строчки, то вам это не удалось.
Собирался. Вижу что не удалось. Содержимое файла подбирал методом научного
тыка.
Как только получил рабочее состояние -- больше не трогал. За указания спасибо,
как-то не пришло в голову что xml ремарится иначе.
>Если вдруг у вас почему-то этой проблемы не было, то это не значит,
>что её не будет ни у кого.
Данная проблема есть у всех пользователей 4-4.1. И до настоящего момента мною
решалась копированием этого файла и перезапуском hal, ибо других вариантов у
меня не было. Если у Вас есть более правильное решение, пожалуйста, поделитесь.

Отдельно прошу Вас сменить тон Ваших комментариев, либо не отвечать на мои.  
------- Comment #8 From 2008-09-22 16:22:00 -------

*** This bug has been marked as a duplicate of bug 17055 ***