Bug 17317 - Инсталятор ALD4.1 beta создает некорректный xorg.conf
: Инсталятор ALD4.1 beta создает некорректный xorg.conf
Status: CLOSED FIXED
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.1.0
: x86 Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-24 14:50 by
Modified: 2008-11-28 14:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-24 14:50:31
Ставил из iso, собранного из коммита 485db6a91d61b782e665ba89db88bd9d5016e6be
ALD4.1 ставится нормально, за исключением багов, у которых ноги, возможно,
растут из https://bugzilla.altlinux.org/show_bug.cgi?id=17213

Инсталятор создал вот такой xorg.conf:
Section "ServerLayout"
    Identifier     "Minimal layout"
    Screen         "Screen0" 0 0
EndSection

Section "InputDevice"
    Identifier  "/dev/ttyS0"
    Driver      ""
    Option        "Device" "/dev/ttyS0"
    Option        "Protocol" "microsoft"
EndSection

Section "Device"
    Identifier  "Card0|0"
    Driver      ""
EndSection

4.0 делал так:

Section "ServerLayout"
    Identifier     "Minimal layout"
    Screen         "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "ImPS/2 Generic Wheel Mouse|0" "CorePointer"
EndSection

Section "InputDevice"
    Identifier  "ImPS/2 Generic Wheel Mouse|0"
    Driver      "mouse"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "IMPS/2"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "Device"
    Identifier  "Card0|0"
    Driver      "nvidia"
EndSection

К тому же если вручную написать Driver "nvidia" в Section "Device" и
перезагрузить оконный менеджер, то комп мертво зависает. Если Driver "nv", то
оконный менеджер стартует нормально.
Далее в альтераторе выбираю драйвер nvidia - это ожидаемо приводит к зависанию
системы, но после перезагрузки все работает корректно причем с драйверами
nvidia.
Видео GF 7300, проц Celeron 2400, мать noname какая-то, мышь и клавиатура
стандартные.
Можно снести систему и поставить снова - проблема стабильно воспроизводится.
Какую инфу еще предоставить?
------- Comment #1 From 2008-09-24 15:04:13 -------
Видимо, зависание происходило из-за незапуска x11setupdrv. А альтератор разве
не должен его дёргать?
------- Comment #2 From 2008-09-25 12:08:36 -------
есть подозрение что это та неудачная бета то 19.09
------- Comment #3 From 2008-09-25 12:22:24 -------
Ага, проблема с видеодрайвером была решена в alterator-x11-0.20-alt2.M41.4
Проблема с мышиным драйвером - в installer-0.7-alt27 (как я понимаю с ним еще
дистрибутив не собирался)
------- Comment #4 From 2008-11-28 14:47:46 -------
old bug, notabug for now