Bug 17446 - Собрать без gnome-libs-devel
: Собрать без gnome-libs-devel
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/gdk-pixbuf)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-06 11:41 by
Modified: 2008-12-10 20:39 (History)


Attachments
Gdk-pixbuf with dropped gnome support (8.96 KB, text/plain)
2008-12-07 15:34, Evgenii Terechkov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-06 11:41:12
По результату обсуждения в devel@:

Subject: Re: [devel] gnome-commander застрял в incoming
--text follows this line--
Vitaly Lipatov пишет:

> On 6 октября 2008, Alexey Tourbin wrote:
>>> Куда делся пакет gnome-libs-devel?
>> Это очень старый GNOME1 пакет, который возрождать, по-видимому, не следует.

> Что-то для меня это не столь очевидно. Судя по cybertalk, вынос
> gnome-libs-devel тянет за собой ещё по меньшей мере 20 пакетов
> (транзитивно). Не думаю, что все они уже не нужны.
> В частности, мне нужен xosd (gnome-libs-devel -> gdk-pixbuf-devel -> xosd).
> Попробую посмотреть на досуге, можно ли оторвать такую зависимость. Если не
> получится - видимо, придётся гальванизировать трупик gnome-libs-devel.

>> Прошу не гальванизировать.  Ещё пять лет назад обсуждали,
>> продолжать ли поддерживать GNOME1 или нет.  gdk-pixbuf можно
>> собрать без gnome-libs.

Хорошо бы отвязать gdk-pixbuf от этого старья.
------- Comment #1 From 2008-12-07 15:34:56 -------
Created an attachment (id=3118) [details]
Gdk-pixbuf with dropped gnome support

*ping*?
------- Comment #2 From 2008-12-07 15:47:50 -------
(In reply to comment #0)
> Хорошо бы отвязать gdk-pixbuf от этого старья.
gdk-pixbuf, напоминаю, старьё не меньшее.
------- Comment #3 From 2008-12-07 16:20:02 -------
Без него какбе xosd-xmms не собираеца. Старьё тоже, но пользуют.
------- Comment #4 From 2008-12-08 17:15:49 -------
Пожалуйста, перестаньте мучить старушку и дайте ей умереть естественной
смертью! Я обещаю поддерживать её жизнедеятельность пока есть приложения, от
неё зависящие и не вижу смысла в каких-либо изменениях.
------- Comment #5 From 2008-12-08 18:24:28 -------
Т.е. вы предлагаете приложение, зависящее от неё (xmms-osd), поддержать через
убиение? Хорошо, так и запишем.
------- Comment #6 From 2008-12-10 10:31:35 -------
Я предлагаю оставить gdk-pixbuf в текущем состоянии (а сейчас он
работоспособен) и ничего от него не отрывать. Под естественной смертью я
подразумеваю естественный уход пакета в obsoletes когда от него ничего не будет
зависеть. Или xmms-osd не собирается именно из-за того, что gdk-pixbuf собран с
поддержкой gnome-libs?
------- Comment #7 From 2008-12-10 12:57:28 -------
(In reply to comment #6)
> Я предлагаю оставить gdk-pixbuf в текущем состоянии (а сейчас он работоспособен)
> и ничего от него не отрывать. Под естественной смертью я подразумеваю
> естественный уход пакета в obsoletes когда от него ничего не будет зависеть. Или
> xmms-osd не собирается именно из-за того, что gdk-pixbuf собран с поддержкой gnome-libs?
> 

Читай выше: gnome-libs-devel -> gdk-pixbuf-devel -> xosd. Последний не
собирается т.к. gtk-pixbuf-devel собран с тем, чего в Сизифе уже нет. Т.е., он
может и работоспособен, но не пересобирается.
------- Comment #8 From 2008-12-10 14:33:42 -------
Думаю, что лучше в данном случае не демонстрировать собственное всезнание
вопроса (плавно переходящее в незнание), а либо спросить у мэйнтейнера
gnome-libs (меня то есть), либо посмотреть на sisyphus.ru:
http://www.sisyphus.ru/srpm/Sisyphus/gnome-libs

И понять, что gnome-libs живее всех живых...
------- Comment #9 From 2008-12-10 20:39:45 -------
Верно, не углядел, что его обновили.

Собственно, меня смущало то, что и с хост-систему и в хашер gnome-libs-devel у
меня (не) устанавливаются вот так:

evg@evg ~ $ sudo apt-get gnome-libs-devel
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  gnome-libs-devel: Требует: gnome-libs (= 1.4.2-alt8)
                    Требует: /usr/lib/libart_lgpl.so.2.2.0
                    Требует: /usr/lib/libgnome.so.32.4.3
                    Требует: /usr/lib/libgnomesupport.so.0.0.0
                    Требует: /usr/lib/libgnomeui.so.32.14.1
                    Требует: /usr/lib/libgnorba.so.27.1.8
                    Требует: /usr/lib/libgnorbagtk.so.0.0.0
                    Требует: /usr/lib/libgtkxmhtml.so.1.0.1
                    Требует: /usr/lib/libzvt.so.2.3.0
E: Извините, `битые' пакеты
[1]    22710 exit 100   sudo apt-get install gnome-libs-devel
evg@evg ~ $ sudo apt-get gnome-libs-devel gnome-libs      
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  ORBit ORBit-devel db1-utils esd glib-devel gtk+-devel imlib-cfgeditor
imlib-devel indent libICE-devel libORBit libSM-devel
  libXext-devel libXpm-devel libalsa-devel libaudiofile-devel libdb1
libdb1-devel libesd-devel libjpeg-devel libpng-devel
  libtiff-devel libungif-devel zlib-devel
Следующие НОВЫЕ пакеты будут установлены:
  ORBit ORBit-devel db1-utils esd glib-devel gnome-libs gnome-libs-devel
gtk+-devel imlib-cfgeditor imlib-devel indent
  libICE-devel libORBit libSM-devel libXext-devel libXpm-devel libalsa-devel
libaudiofile-devel libdb1 libdb1-devel
  libesd-devel libjpeg-devel libpng-devel libtiff-devel libungif-devel
zlib-devel
0 будет обновлено, 26 новых установлено, 0 пакетов будет удалено и 4 не будет
обновлено.
Необходимо получить 0B/4569kB архивов.
После распаковки потребуется дополнительно 16,5MB дискового пространства.
Продолжить? [Y/n] n
Прервано.

И xosd в хашере с нужными пакетами таки собирается. Так что ошибка сплошь моя.
Извиняюсь.