Bug 17531 - Отсутствует зависимость на пакет glibc-devel
: Отсутствует зависимость на пакет glibc-devel
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/lazarus)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-10-11 18:21 by
Modified: 2009-05-02 12:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-10-11 18:21:41
Для сборки программ в Lazarus необходима установка пакета glibc-devel

Подробности здесь: 
http://lists.altlinux.org/pipermail/community/2008-October/419078.html
------- Comment #1 From 2008-10-13 16:33:06 -------
Исправленная сборка ушла в сизиф.
------- Comment #2 From 2009-01-21 10:27:25 -------
*** Bug 18583 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2009-01-22 14:10:18 -------
Вот здесь
http://lists.altlinux.org/pipermail/community/2008-October/419118.html
приведён список библиотек, который должен быть установлен в системе для
компиляции проекта. Однако в зависимостях пакета часть из этих библиотек 
почему-то отсутствуют, что приводит к невозможности компляции пустого проекта
после установки пакета. 

$ for i in glibc-devel glib-devel gdk-pixbuf-devel libXi-devel gtk+-devel ; do
rpmquery --requires -p lazarus-0.9.24-alt3.2.i586.rpm | fgrep -q $i || echo
missing dependency: $i ; done
missing dependency: glibc-devel
missing dependency: libXi-devel
------- Comment #4 From 2009-04-05 03:35:06 -------
Добавлено в 0.9.24-alt3.4.